source: trunk/debathena/config/cluster-login-config/debian/rules @ 24668

Revision 24668, 2.1 KB checked in by broder, 14 years ago (diff)
In cluster-login-config: * Replace /sbin/getty instead of diverting the tty jobs. * Use ConsoleKit to activate the user's session instead of telling them to press a key combo. (Trac: #547)
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3GDM_VERSION = $(shell dpkg-query --showformat='$${Version}' --show gdm)
4NEW_GDM = $(shell dpkg --compare-versions $(GDM_VERSION) ge '2.25.2~' && echo y)
5EVENT_D = $(shell test -f /etc/event.d/tty1 && echo y)
6
7DEB_DIVERT_EXTENSION = .debathena
8ifneq ($(wildcard /etc/gdm/gdm.conf-custom.debathena),)
9    GDM_CONFFILE = /etc/gdm/gdm.conf-custom.debathena.debathena
10else
11    GDM_CONFFILE = /etc/gdm/gdm.conf.debathena.debathena
12endif
13DEB_UNDIVERT_FILES_debathena-cluster-login-config += \
14        /etc/default/kexec.debathena
15DEB_UNDIVERT_VERSION_/etc/default/kexec.debathena = 1.23~
16
17ifneq ($(NEW_GDM),y)
18    DEB_TRANSFORM_FILES_debathena-cluster-login-config += \
19        ${GDM_CONFFILE}
20else
21    DEB_REMOVE_FILES_debathena-cluster-login-config += \
22        /usr/share/xsessions/gnome-failsafe.desktop \
23        /usr/share/xsessions/xterm.desktop
24endif
25
26DEB_REMOVE_FILES_debathena-cluster-login-config += \
27    /usr/lib/indicator-session/indicator-users-service
28
29DEB_DIVERT_FILES_debathena-cluster-login-config += \
30        /sbin/getty.debathena
31
32ifeq ($(EVENT_D),y)
33    DEB_UNREMOVE_FILES_debathena-cluster-login-config += \
34        /etc/event.d/tty1 \
35        /etc/event.d/tty2 \
36        /etc/event.d/tty3 \
37        /etc/event.d/tty4 \
38        /etc/event.d/tty5 \
39        /etc/event.d/tty6
40    DEB_UNREMOVE_VERSION_/etc/event.d/tty1 = 1.24~
41    DEB_UNREMOVE_VERSION_/etc/event.d/tty2 = 1.24~
42    DEB_UNREMOVE_VERSION_/etc/event.d/tty3 = 1.24~
43    DEB_UNREMOVE_VERSION_/etc/event.d/tty4 = 1.24~
44    DEB_UNREMOVE_VERSION_/etc/event.d/tty5 = 1.24~
45    DEB_UNREMOVE_VERSION_/etc/event.d/tty6 = 1.24~
46else
47    DEB_UNREMOVE_FILES_debathena-cluster-login-config += \
48        /etc/init/tty1.conf \
49        /etc/init/tty2.conf \
50        /etc/init/tty3.conf \
51        /etc/init/tty4.conf \
52        /etc/init/tty5.conf \
53        /etc/init/tty6.conf
54    DEB_UNREMOVE_VERSION_/etc/init/tty1.conf = 1.24~
55    DEB_UNREMOVE_VERSION_/etc/init/tty2.conf = 1.24~
56    DEB_UNREMOVE_VERSION_/etc/init/tty3.conf = 1.24~
57    DEB_UNREMOVE_VERSION_/etc/init/tty4.conf = 1.24~
58    DEB_UNREMOVE_VERSION_/etc/init/tty5.conf = 1.24~
59    DEB_UNREMOVE_VERSION_/etc/init/tty6.conf = 1.24~
60endif
61
62include /usr/share/cdbs/1/rules/debhelper.mk
63include /usr/share/cdbs/1/rules/config-package.mk
Note: See TracBrowser for help on using the repository browser.