source: trunk/debathena/config/finger-config/debian/rules @ 25031

Revision 25031, 685 bytes checked in by jdreed, 13 years ago (diff)
In finger-config: * Replace and Conflict debathena-finger (<= 10.0.2-0debathena1) * Ship a tiny finger wrapper which adds -m on older platforms
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3FINGER_VERSION = $(shell dpkg-query --showformat='$${Version}' --show bsd-finger)
4# From the changelog for bsd-finger
5NEW_FINGER = $(shell dpkg --compare-versions $(FINGER_VERSION) ge '0.17-13~' && echo y)
6
7DEB_DIVERT_EXTENSION = .debathena
8
9ifneq ($(NEW_FINGER),y)
10    # Older packages, continue to divert
11    DEB_DIVERT_FILES_debathena-finger-config += \
12        /usr/bin/finger.debathena
13    DEB_UNDIVERT_FILES_debathena-finger-config += \
14        /usr/share/man/man1/finger.debathena.1.gz
15    DEB_UNDIVERT_VERSION_/usr/share/man/man1/finger.debathena.1.gz = 1.0debathena3~
16endif
17
18include /usr/share/cdbs/1/rules/debhelper.mk
19include /usr/share/cdbs/1/rules/config-package.mk
Note: See TracBrowser for help on using the repository browser.