source: trunk/debathena/config/from-config/debian/rules @ 25127

Revision 25127, 1.1 KB checked in by geofft, 13 years ago (diff)
In from-config: * Use config-package-dev 4.12 (yay) to handle undiversions, instead of a copy of a broken version of its undiversions code.
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3BSDMAINUTILS_VERSION = $(shell dpkg-query --showformat='$${Version}' --show bsdmainutils)
4# From the changelog for bsdmainutils
5USES_ALTERNATIVES = $(shell dpkg --compare-versions $(BSDMAINUTILS_VERSION) ge '8.0.6~' && echo y)
6
7DEB_DIVERT_EXTENSION = .debathena
8ifneq ($(USES_ALTERNATIVES),y)
9    # Older packages, continue to divert
10    DEB_DIVERT_FILES_debathena-from-config += \
11        /usr/bin/from.debathena \
12        /usr/share/man/man1/from.debathena.1.gz
13    binary-predeb/debathena-from-config::
14        echo "debathena-from-config-breaks=bsdmainutils (>= 8.0.6~)" >> debian/debathena-from-config.substvars
15else
16    # Newer packages: undivert, generate Conflicts, generate postinst
17    DEB_UNDIVERT_FILES_debathena-from-config += \
18        /usr/bin/from.debathena \
19        /usr/share/man/man1/from.debathena.1.gz
20    binary-predeb/debathena-from-config::
21        echo "debathena-from-config-conflicts=bsdmainutils (<< 8.0.6~)" >> debian/debathena-from-config.substvars
22    common-build-indep::
23        cp -f debian/postinst-alternatives debian/postinst
24    clean::
25        rm -f debian/postinst
26endif
27
28include /usr/share/cdbs/1/rules/debhelper.mk
29include /usr/share/cdbs/1/rules/config-package.mk
30
Note: See TracBrowser for help on using the repository browser.