source: trunk/debathena/config/gdm-config/debian/rules @ 22719

Revision 22719, 834 bytes checked in by tabbott, 16 years ago (diff)
In gdm-config: * New version using graphical theme. * Use gdm.conf-custom instead of gdm.conf when it exists in order to support Ubuntu.
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3ifneq ($(wildcard /etc/gdm/gdm.conf-custom),)
4    GDM_CONFFILE = /etc/gdm/gdm.conf-custom
5else
6    GDM_CONFFILE = /etc/gdm/gdm.conf
7endif
8
9DEB_AUTO_UPDATE_DEBIAN_CONTROL = 1
10DEBATHENA_DIVERT_FILES_debathena-gdm-config += \
11        ${GDM_CONFFILE}.debathena
12include /usr/share/cdbs/1/rules/debhelper.mk
13include /usr/share/cdbs/1/rules/debathena-divert.mk
14include /usr/share/cdbs/1/rules/debathena-check-conffiles.mk
15
16DEB_DH_LINK_ARGS=/etc/gdm/gdm.conf-custom.debathena /etc/gdm/gdm.conf.debathena
17
18common-build-indep:: debian/gdm.conf-custom.debathena
19
20debian/gdm.conf-custom.debathena: $(call debathena_check_conffiles,${GDM_CONFFILE})
21        perl -0pe ' \
22            s/(\[daemon\]\n)/\1UserAuthDir=\/tmp\n/ and \
23            s/(\[greeter\]\n)/\1GraphicalTheme=debathena\n/ or die;' $< > $@
24
25clean::
26        rm -f debian/gdm.conf-custom.debathena
Note: See TracBrowser for help on using the repository browser.