source: trunk/debathena/config/pam-config/debian/rules @ 25730

Revision 25730, 4.0 KB checked in by jdreed, 12 years ago (diff)
In pam-config: * And actually transform /etc/pam.d/gdm3 correctly
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3pam_types = account auth session password
4pam_krb5_auth_opts = use_authtok
5pam_krb5_passwd_opts = use_authtok
6
7DEB_DIVERT_EXTENSION = .debathena
8
9pam_auth_update = $(shell hash pam-auth-update 2>/dev/null && echo yes)
10
11KRB5_VERSION = $(shell dpkg-query -W -f '$${Version}' krb5-clients)
12HAVE_KRB4 = $(shell dpkg --compare-versions $(KRB5_VERSION) '<<' '1.7~' && echo y)
13
14ifeq ($(pam_auth_update),)
15    DEB_TRANSFORM_FILES_debathena-pam-config += \
16        $(patsubst %,/etc/pam.d/common-%.debathena,$(pam_types))
17
18    ifneq ($(wildcard /usr/share/pam/common-auth),)
19        DEB_CHECK_FILES_SOURCE_/etc/pam.d/common-auth.debathena = /usr/share/pam/common-auth
20        DEB_CHECK_FILES_SOURCE_/etc/pam.d/common-session.debathena = /usr/share/pam/common-session
21        DEB_CHECK_FILES_SOURCE_/etc/pam.d/common-account.debathena = /usr/share/pam/common-account
22        DEB_CHECK_FILES_SOURCE_/etc/pam.d/common-password.debathena = /usr/share/pam/common-password
23    endif
24endif
25
26ifneq ($(wildcard /etc/pam.d/gdm3),)
27    PAM_GDM = /etc/pam.d/gdm3.debathena
28    DEB_TRANSFORM_SCRIPT_$(PAM_GDM) = debian/transform_gdm.debathena
29else
30    PAM_GDM = /etc/pam.d/gdm.debathena
31endif
32
33ifneq ($(wildcard /etc/pam.d/sshd),)
34    PAM_SSHD = /etc/pam.d/sshd.debathena
35    DEB_TRANSFORM_SCRIPT_$(PAM_SSHD) = debian/transform_ssh.debathena
36else
37    PAM_SSHD = /etc/pam.d/ssh.debathena
38endif
39
40DEB_TRANSFORM_FILES_debathena-pam-config += \
41        $(PAM_GDM) \
42        $(PAM_SSHD) \
43        /etc/pam.d/login.debathena
44
45DEB_DIVERT_FILES_debathena-pam-config += \
46        /etc/security/access.conf.debathena
47
48DEB_REMOVE_FILES_debathena-pam-config += \
49        /usr/share/pam-configs/krb5 \
50        /usr/share/pam-configs/afs-session
51
52include /usr/share/cdbs/1/rules/debhelper.mk
53include /usr/share/cdbs/1/rules/config-package.mk
54
55DEB_INSTALL_DOCS_debathena-pam-config = debian/README.pam-afs-session
56
57ifneq ($(pam_auth_update),)
58install/debathena-pam-config::
59        install -D -m 644 debian/athena-session-tmpdir-mktemp.pam-config \
60          $(DEB_DESTDIR)/usr/share/pam-configs/athena-session-tmpdir-mktemp
61        install -D -m 644 debian/xdg-cache-home-mktemp.pam-config \
62          $(DEB_DESTDIR)/usr/share/pam-configs/xdg-cache-home-mktemp
63        install -D -m 644 debian/libpam-krb5.pam-config \
64          $(DEB_DESTDIR)/usr/share/pam-configs/krb5.debathena
65        install -D -m 644 debian/libpam-afs-session.pam-config \
66          $(DEB_DESTDIR)/usr/share/pam-configs/afs-session.debathena
67debathena-pam-config-substvars:
68        ( \
69          echo -n "debathena-pam-config-depends="; \
70          echo -n "libpam-runtime (>= 1.0.1-4ubuntu1),"; \
71          echo -n "libpam-krb5,"; \
72          if [ "$(HAVE_KRB4)" = "y" ]; then \
73            echo -n "libpam-krb524 (>= 1.3-0debathena3~),"; \
74          fi; \
75          echo -n "libpam-afs-session,"; \
76          echo -n "libpam-debathena-home-type (>= 1.1-0debathena2~),"; \
77          echo \
78        ) >>debian/debathena-pam-config.substvars
79else
80debathena-pam-config-substvars:
81        ( \
82          echo -n "debathena-pam-config-depends="; \
83          echo -n "libpam-krb5,"; \
84          if [ "$(HAVE_KRB4)" = "y" ]; then \
85            echo -n "libpam-krb524,"; \
86          fi; \
87          echo -n "libpam-afs-session,"; \
88          echo -n "libpam-debathena-home-type,"; \
89          echo \
90        ) >>debian/debathena-pam-config.substvars
91endif
92
93binary-predeb/debathena-pam-config:: debathena-pam-config-substvars
94
95ifneq ($(wildcard /etc/pam.d/sshd),)
96debian-divert/debathena-pam-config::
97        (echo "if [ \"\$$1\" = configure ] && dpkg-divert --list /etc/pam.d/ssh | grep -xFq 'diversion of /etc/pam.d/ssh to /etc/pam.d/ssh.debathena-orig by $(cdbs_curpkg)'; then"; \
98        echo "    undivert_unlink /etc/pam.d/ssh"; \
99        echo "fi") >> $(CURDIR)/debian/$(cdbs_curpkg).postinst.debhelper
100endif
101
102common-build-indep:: debian/access.conf.debathena
103
104LSB_ID = $(shell lsb_release --short --id)
105debian/access.conf.debathena: $(call debian_check_files,/etc/security/access.conf)
106ifeq ($(LSB_ID), Debian)
107        (cat $<; sed 's/root admin /root /' debian/access.conf.append) > $@
108else
109    ifeq ($(LSB_ID), Ubuntu)
110        cat $< debian/access.conf.append > $@
111    else
112        $(error Unrecognized distribution ID $(LSB_ID).)
113    endif
114endif
115
116clean::
117        rm -f debian/access.conf.debathena
Note: See TracBrowser for help on using the repository browser.