Revision 24246,
606 bytes
checked in by broder, 15 years ago
(diff) |
Update the postinst for dealing with rsyslog.
|
-
Property svn:executable set to
*
|
Rev | Line | |
---|
[23160] | 1 | #!/usr/bin/make -f |
---|
| 2 | |
---|
| 3 | DEB_DIVERT_EXTENSION = .debathena |
---|
[24241] | 4 | |
---|
| 5 | ifneq ($(wildcard /etc/syslog.conf),) |
---|
| 6 | DAEMON = sysklogd |
---|
| 7 | DEB_TRANSFORM_FILES_debathena-syslog-config += \ |
---|
[23160] | 8 | /etc/syslog.conf.debathena |
---|
[24241] | 9 | else ifneq ($(wildcard /etc/rsyslog.d),) |
---|
| 10 | DAEMON = rsyslog |
---|
| 11 | else |
---|
[24246] | 12 | # If you change this, be sure to update the postinst, too |
---|
[24241] | 13 | $(error Unknown default syslog daemon.) |
---|
| 14 | endif |
---|
| 15 | |
---|
[23160] | 16 | include /usr/share/cdbs/1/rules/debhelper.mk |
---|
| 17 | include /usr/share/cdbs/1/rules/config-package.mk |
---|
[24241] | 18 | |
---|
| 19 | ifeq ($(DAEMON),rsyslog) |
---|
| 20 | install/debathena-syslog-config:: |
---|
| 21 | dh_install debian/50-debathena-syslog-config.conf etc/rsyslog.d |
---|
| 22 | endif |
---|
Note: See
TracBrowser
for help on using the repository browser.