source: trunk/debathena/config/syslog-config/debian/rules @ 24241

Revision 24241, 544 bytes checked in by broder, 15 years ago (diff)
In syslog-config: * Configure the default syslog daemon, instead of always configuring sysklogd.
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3DEB_DIVERT_EXTENSION = .debathena
4
5ifneq ($(wildcard /etc/syslog.conf),)
6    DAEMON = sysklogd
7    DEB_TRANSFORM_FILES_debathena-syslog-config += \
8        /etc/syslog.conf.debathena
9else ifneq ($(wildcard /etc/rsyslog.d),)
10    DAEMON = rsyslog
11else
12    $(error Unknown default syslog daemon.)
13endif
14
15include /usr/share/cdbs/1/rules/debhelper.mk
16include /usr/share/cdbs/1/rules/config-package.mk
17
18ifeq ($(DAEMON),rsyslog)
19    install/debathena-syslog-config::
20        dh_install debian/50-debathena-syslog-config.conf etc/rsyslog.d
21endif
Note: See TracBrowser for help on using the repository browser.