source: trunk/debathena/config/tex-config/debian/debathena-tex-config.postinst @ 25416

Revision 25416, 1.2 KB checked in by geofft, 13 years ago (diff)
In tex-config: * Since 1.1, fmtutil-sys may not necessarily be installed, so test if it's there before calling it. (If it's not called, that's fine.) Closes part of Trac: #669.
  • Property svn:executable set to *
Line 
1#!/bin/sh
2# postinst script for debathena-tex-config
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# dh_installdeb will replace this with shell code automatically
9# generated by other debhelper scripts.
10
11#DEBHELPER#
12
13# summary of how this script can be called:
14#        * <postinst> `configure' <most-recently-configured-version>
15#        * <old-postinst> `abort-upgrade' <new version>
16#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
17#          <new-version>
18#        * <postinst> `abort-remove'
19#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
20#          <failed-install-package> <version> `removing'
21#          <conflicting-package> <version>
22# for details, see http://www.debian.org/doc/debian-policy/ or
23# the debian-policy package
24
25
26case "$1" in
27    configure)
28        # If fmtutil-sys is not currently available, that's okay;
29        # our config will get picked up in the triggers or postinsts
30        # of TeX packages when they do get installed.
31        if hash fmtutil-sys 2>/dev/null; then
32            fmtutil-sys --all
33        fi
34    ;;
35
36    abort-upgrade|abort-remove|abort-deconfigure)
37    ;;
38
39    *)
40        echo "postinst called with unknown argument \`$1'" >&2
41        exit 1
42    ;;
43esac
44
45exit 0
46
47
Note: See TracBrowser for help on using the repository browser.