source: trunk/debathena/debathena/dotfiles/debian/debathena-dotfiles.postinst @ 22798

Revision 22798, 1.1 KB checked in by ghudson, 17 years ago (diff)
* debathena/debathena/dotfiles: Copy packs/dotfiles back from the attic and import the Debathena packaging materials. The goal is to simplify this source tree by eliminating multi-OS concerns, but starting from the existing tree seems easiest.
Line 
1#!/bin/sh
2# postinst script for debathena-dotfiles
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20
21case "$1" in
22    configure)
23        if ! dpkg-statoverride --list /var/run/athena-sessions >/dev/null; then
24            chmod a=rwx,u+t /var/run/athena-sessions
25        fi
26    ;;
27
28    abort-upgrade|abort-remove|abort-deconfigure)
29    ;;
30
31    *)
32        echo "postinst called with unknown argument \`$1'" >&2
33        exit 1
34    ;;
35esac
36
37# dh_installdeb will replace this with shell code automatically
38# generated by other debhelper scripts.
39
40#DEBHELPER#
41
42exit 0
43
44
Note: See TracBrowser for help on using the repository browser.