source: trunk/debathena/debathena/dotfiles/debian/rules @ 23298

Revision 23298, 662 bytes checked in by tabbott, 16 years ago (diff)
In dotfiles: * Remove DEB_AUTO_UPDATE_DEBIAN_CONTROL. * Change "Debian-Athena Project" to "Debathena Project". * Remove debian/control from version control. * Clean up debian/copyright.
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3include /usr/share/cdbs/1/rules/debhelper.mk
4include /usr/share/cdbs/1/class/makefile.mk
5include /usr/share/cdbs/1/rules/patchsys-quilt.mk
6
7OS = linux
8ATHENA_MAJOR_VERSION = 9
9ATHENA_MINOR_VERSION = 4
10
11DEB_MAKE_INSTALL_TARGET = install DESTDIR=$(DEB_DESTDIR)
12DEB_MAKE_INVOKE += OS=$(OS) ATHENA_MAJOR_VERSION=$(ATHENA_MAJOR_VERSION) ATHENA_MINOR_VERSION=$(ATHENA_MINOR_VERSION)
13DEB_DESTDIR = $(CURDIR)/debian/tmp/
14DEB_DH_INSTALL_SOURCEDIR = $(DEB_DESTDIR)
15DEB_DH_INSTALLINIT_ARGS = --no-start
16DEB_UPDATE_RCD_PARAMS = "start 65 S ."
17
18common-install::
19        chmod a=rwx,o+t $(DEB_DESTDIR)/var/run/athena-sessions
20
21clean::
22        rm -f gnome/athena.schemas
Note: See TracBrowser for help on using the repository browser.