source: trunk/third/gstreamer/gstreamer.spec @ 18743

Revision 18743, 14.3 KB checked in by ghudson, 21 years ago (diff)
This commit was generated by cvs2svn to compensate for changes in r18742, which included commits to RCS files with non-trunk default branches.
Line 
1Name:           gstreamer
2Version:        0.5.2.3
3Release:        20030130_235633
4Summary:        GStreamer streaming media framework runtime.
5
6Group:          Libraries/Multimedia
7License:        LGPL
8URL:            http://gstreamer.net/
9Vendor:         GStreamer Backpackers Team <package@gstreamer.net>
10Source:         http://gstreamer.net/releases/%{version}/src/%{name}-%{version}.tar.gz
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12
13%define         majorminor      0.6
14%define         _glib2          2.0.1
15%define         _libxml2        2.4.0
16
17Requires:       glib2 >= %_glib2
18Requires:       libxml2 >= %_libxml2
19Requires:       popt > 1.6
20Prereq:         %{name}-tools >= %{version}
21BuildRequires:  glib2-devel >= %_glib2
22BuildRequires:  libxml2-devel >= %_libxml2
23BuildRequires:  bison
24BuildRequires:  flex
25BuildRequires:  gtk-doc >= 0.7
26BuildRequires:  gcc
27BuildRequires:  zlib-devel
28BuildRequires:  popt > 1.6
29Prereq:         /sbin/ldconfig
30
31### documentation requirements
32BuildRequires:  openjade
33BuildRequires:  python2
34BuildRequires:  docbook-style-dsssl docbook-dtd31-sgml
35BuildRequires:  transfig xfig
36
37%description
38GStreamer is a streaming-media framework, based on graphs of filters which
39operate on media data. Applications using this library can do anything
40from real-time sound processing to playing videos, and just about anything
41else media-related.  Its plugin-based architecture means that new data
42types or processing capabilities can be added simply by installing new
43plugins.
44
45%package devel
46Summary:        Libraries/include files for GStreamer streaming media framework.
47Group:          Development/Libraries
48
49Requires:       %{name} = %{version}-%{release}
50Requires:       glib2-devel >= %_glib2
51Requires:       libxml2-devel >= %_libxml2
52
53%description devel
54GStreamer is a streaming-media framework, based on graphs of filters which
55operate on media data. Applications using this library can do anything
56from real-time sound processing to playing videos, and just about anything
57else media-related.  Its plugin-based architecture means that new data
58types or processing capabilities can be added simply by installing new   
59plugins.
60
61This package contains the libraries and includes files necessary to develop
62applications and plugins for GStreamer.
63
64%package tools
65Summary:        tools for GStreamer streaming media framework.
66Group:          Libraries/Multimedia
67Requires:       %{name}
68
69%description tools
70GStreamer is a streaming-media framework, based on graphs of filters which
71operate on media data. Applications using this library can do anything
72from real-time sound processing to playing videos, and just about anything
73else media-related.  Its plugin-based architecture means that new data
74types or processing capabilities can be added simply by installing new   
75plugins.
76
77This package contains the basic command-line tools used for GStreamer, like
78gst-register and gst-launch.  It is split off to allow parallel-installability
79in the future.
80
81%prep
82%setup
83
84%build
85CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS ; \
86CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS ; \
87FFLAGS="${FFLAGS:-%optflags}" ; export FFLAGS ; \
88%{?__libtoolize:[ -f configure.in ] && %{__libtoolize} --copy --force} ; \
89./configure \
90  --prefix=%{_prefix} \
91  --exec-prefix=%{_exec_prefix} \
92  --bindir=%{_bindir} \
93  --sbindir=%{_sbindir} \
94  --sysconfdir=%{_sysconfdir} \
95  --datadir=%{_datadir} \
96  --includedir=%{_includedir} \
97  --libdir=%{_libdir} \
98  --libexecdir=%{_libexecdir} \
99  --localstatedir=%{_localstatedir} \
100  --sharedstatedir=%{_sharedstatedir} \
101  --mandir=%{_mandir} \
102  --infodir=%{_infodir} \
103  --enable-debug \
104  --with-cachedir=%{_localstatedir}/cache/gstreamer-%{majorminor} \
105  --disable-tests --disable-examples \
106  --enable-docs-build --with-html-dir=$RPM_BUILD_ROOT%{_datadir}/gtk-doc/html
107
108if [ "$SMP" != "" ]; then
109  (make "MAKE=make -k -j $SMP"; exit 0)
110else
111  make
112fi
113
114%install 
115[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
116# adding devhelp stuff here for now, need to integrate better
117# when devhelp allows it
118mkdir -p $RPM_BUILD_ROOT/usr/share/devhelp/specs
119cp $RPM_BUILD_DIR/%{name}-%{version}/docs/devhelp/*.devhelp $RPM_BUILD_ROOT/usr/share/devhelp/specs
120
121%makeinstall
122# Clean out files that should not be part of the rpm.
123# This is the recommended way of dealing with it for RH8
124mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/gstreamer-%{majorminor}
125rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}-%{majorminor}/*.la
126rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}-%{majorminor}/*.a
127rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
128rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
129
130%clean
131[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
132
133%post
134/sbin/ldconfig
135%{_bindir}/gst-register --gst-mask=0 > /dev/null 2> /dev/null
136
137%post devel
138# adding devhelp links to work around different base not working
139mkdir -p %{_datadir}/devhelp/books
140ln -sf %{_datadir}/gtk-doc/html/gstreamer %{_datadir}/devhelp/books
141ln -sf %{_datadir}/gtk-doc/html/gstreamer-libs %{_datadir}/devhelp/books
142
143%postun
144/sbin/ldconfig
145
146%files
147%defattr(-, root, root)
148%doc AUTHORS COPYING README TODO COPYING.LIB ABOUT-NLS REQUIREMENTS DOCBUILDING RELEASE
149%{_libdir}/libgstreamer-%{majorminor}.so.*
150%{_libdir}/libgstcontrol-%{majorminor}.so.*
151%dir %{_libdir}/gstreamer-%{majorminor}
152%dir %{_localstatedir}/cache/gstreamer-%{majorminor}
153%{_libdir}/gstreamer-%{majorminor}/libgstautoplugcache*.so*
154%{_libdir}/gstreamer-%{majorminor}/libgstautoplugger*.so*
155%{_libdir}/gstreamer-%{majorminor}/libgstbasicomega*.so*
156%{_libdir}/gstreamer-%{majorminor}/libgstoptscheduler.so*
157%{_libdir}/gstreamer-%{majorminor}/libgstoptomega*.so*
158%{_libdir}/gstreamer-%{majorminor}/libgstbasicwingo*.so*
159%{_libdir}/gstreamer-%{majorminor}/libgstoptwingoscheduler*.so
160%{_libdir}/gstreamer-%{majorminor}/libgstelements*.so*
161%{_libdir}/gstreamer-%{majorminor}/libgsttypes*.so*
162%{_libdir}/gstreamer-%{majorminor}/libgststaticautoplug*.so*
163%{_libdir}/gstreamer-%{majorminor}/libgstbytestream*.so*
164%{_libdir}/gstreamer-%{majorminor}/libgstgetbits*.so*
165%{_libdir}/gstreamer-%{majorminor}/libgstputbits*.so*
166%{_libdir}/gstreamer-%{majorminor}/libgstspider*.so*
167%{_libdir}/gstreamer-%{majorminor}/libgstindexers.so
168
169%files tools
170%{_bindir}/gst-complete
171%{_bindir}/gst-compprep
172%{_bindir}/gst-inspect
173%{_bindir}/gst-launch
174%{_bindir}/gst-md5sum
175%{_bindir}/gst-register
176%{_bindir}/gst-feedback
177%{_bindir}/gst-xmllaunch
178%{_mandir}/man1/gst-feedback.*
179%{_mandir}/man1/gst-xmllaunch.*
180%{_mandir}/man1/gst-complete.*
181%{_mandir}/man1/gst-compprep.*
182%{_mandir}/man1/gst-inspect.*
183%{_mandir}/man1/gst-launch.*
184%{_mandir}/man1/gst-md5sum.*
185%{_mandir}/man1/gst-register.*
186
187
188%files devel
189%defattr(-, root, root)
190%dir %{_includedir}/%{name}-%{majorminor}
191%dir %{_includedir}/%{name}-%{majorminor}/gst
192%{_includedir}/%{name}-%{majorminor}/gst/*.h
193%dir %{_includedir}/%{name}-%{majorminor}/gst/control
194%{_includedir}/%{name}-%{majorminor}/gst/control/*.h
195%dir %{_includedir}/%{name}-%{majorminor}/gst/bytestream
196%{_includedir}/%{name}-%{majorminor}/gst/bytestream/bytestream.h
197%dir %{_includedir}/%{name}-%{majorminor}/gst/getbits
198%{_includedir}/%{name}-%{majorminor}/gst/getbits/getbits.h
199%dir %{_includedir}/%{name}-%{majorminor}/gst/putbits
200%{_includedir}/%{name}-%{majorminor}/gst/putbits/putbits.h
201# %{_libdir}/libgstreamer.a
202%{_libdir}/libgstreamer-%{majorminor}.so
203%{_libdir}/libgstcontrol-%{majorminor}.so
204%{_libdir}/pkgconfig/gstreamer-%{majorminor}.pc
205%{_libdir}/pkgconfig/gstreamer-control-%{majorminor}.pc
206## we specify the API docs as regular files since %docs doesn't fail when
207#  files aren't found anymore for RPM >= 4
208#  we list all of the files we really need to trap incomplete doc builds
209#  then we catch the rest with *, you can safely ignore the errors from this
210## gstreamer API
211%dir %{_datadir}/gtk-doc/html/%{name}-%{majorminor}
212%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/autopluggers.html
213%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/book1.html
214%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/element-types.html
215%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/gstautoplugfactory.html
216%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/gstautoplug.html
217%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/gstbin.html
218%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/gstclock.html
219%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/gstelement.html
220%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/gst-index.html
221%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/gstobject.html
222%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/gstpad.html
223%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/gstpipeline.html
224%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/gstpluginfeature.html
225# %{_datadir}/gtk-doc/html/%{name}-%{majorminor}/gstreamer-cothreads.html
226%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/gstreamer-gstbuffer.html
227%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/gstreamer-gstbufferpool.html
228%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/gstreamer-gstcaps.html
229%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/gstreamer-gstcpu.html
230%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/gstreamer-gstdata.html
231%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/gstreamer-gstevent.html
232%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/gstreamer-gst.html
233%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/gstreamer-gstinfo.html
234%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/gstreamer-gstparse.html
235%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/gstreamer-gstplugin.html
236%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/gstreamer-gstprops.html
237%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/gstreamer-gststaticautoplug.html
238%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/gstreamer-gststaticautoplugrender.html
239%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/gstreamer-gsttype.html
240%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/gstreamer-gstutils.html
241%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/gstreamer.html
242%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/gstschedulerfactory.html
243%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/gstscheduler.html
244%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/gstthread.html
245%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/gsttypefactory.html
246%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/gstxml.html
247%{_datadir}/gtk-doc/html/%{name}-%{majorminor}/index.sgml
248## gstreamer-libs API
249%dir %{_datadir}/gtk-doc/html/%{name}-libs-%{majorminor}
250%{_datadir}/gtk-doc/html/%{name}-libs-%{majorminor}/book1.html
251%{_datadir}/gtk-doc/html/%{name}-libs-%{majorminor}/%{name}-libs-gstcolorspace.html
252%{_datadir}/gtk-doc/html/%{name}-libs-%{majorminor}/%{name}-libs-gstgetbits.html
253%{_datadir}/gtk-doc/html/%{name}-libs-%{majorminor}/%{name}-libs.html
254%{_datadir}/gtk-doc/html/%{name}-libs-%{majorminor}/index.sgml
255## this catches all of the rest of the docs we might have forgotten
256%{_datadir}/gtk-doc/html/*
257%{_datadir}/devhelp/specs/%{name}-%{majorminor}.devhelp
258%{_datadir}/devhelp/specs/%{name}-libs-%{majorminor}.devhelp
259
260
261%changelog
262* Tue Jan 28 2003 Thomas Vander Stichele <thomas at apestaart dot org>
263- added gstreamer-control.pc file
264
265* Sat Dec 07 2002 Thomas Vander Stichele <thomas at apestaart dot org>
266- define majorminor and use it everywhere
267- full parallel installability
268
269* Tue Nov 05 2002 Christian Schaller <Uraeus@linuxrising.org>
270- Add optwingo scheduler
271
272* Sat Oct 12 2002 Christian Schaller <Uraeus@linuxrising.org>
273- Updated to work better with default RH8 rpm
274- Added missing unspeced files
275- Removed .a and .la files from buildroot
276
277* Sat Sep 21 2002 Thomas Vander Stichele <thomas@apestaart.org>
278- added gst-md5sum
279
280* Tue Sep 17 2002 Thomas Vander Stichele <thomas@apestaart.org>
281- adding flex to buildrequires
282
283* Fri Sep 13 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
284- Fixed the schedulers after the renaming
285* Sun Sep 08 2002 Thomas Vander Stichele <thomas@apestaart.org>
286- added transfig to the BuildRequires:
287
288* Sat Jun 22 2002 Thomas Vander Stichele <thomas@apestaart.org>
289- moved header location
290
291* Mon Jun 17 2002 Thomas Vander Stichele <thomas@apestaart.org>
292- added popt
293- removed .la
294
295* Fri Jun 07 2002 Thomas Vander Stichele <thomas@apestaart.org>
296- added release of gstreamer to req of gstreamer-devel
297- changed location of API docs to be in gtk-doc like other gtk-doc stuff
298- reordered SPEC file
299
300* Mon Apr 29 2002 Thomas Vander Stichele <thomas@apestaart.org>
301- moved html docs to gtk-doc standard directory
302
303* Tue Mar 5 2002 Thomas Vander Stichele <thomas@apestaart.org>
304- move version defines of glib2 and libxml2 to configure.ac
305- add BuildRequires for these two libs
306
307* Sun Mar 3 2002 Thomas Vander Stichele <thomas@apestaart.org>
308- put html docs in canonical place, avoiding %doc erasure
309- added devhelp support, current install of it is hackish
310
311* Sat Mar 2 2002 Christian Schaller <Uraeus@linuxrising.org>
312- Added documentation to build
313
314* Mon Feb 11 2002 Thomas Vander Stichele <thomas@apestaart.org>
315- added libgstbasicscheduler
316- renamed libgst to libgstreamer
317
318* Fri Jan 04 2002 Christian Schaller <Uraeus@linuxrising.org>
319- Added configdir parameter as it seems the configdir gets weird otherwise
320
321* Thu Jan 03 2002 Thomas Vander Stichele <thomas@apestaart.org>
322- split off gstreamer-editor from core
323- removed gstreamer-gnome-apps
324
325* Sat Dec 29 2001 Rodney Dawes <dobey@free.fr>
326- Cleaned up the spec file for the gstreamer core/plug-ins split
327- Improve spec file
328
329* Sat Dec 15 2001 Christian Schaller <Uraeus@linuxrising.org>
330- Split of more plugins from the core and put them into their own modules
331- Includes colorspace, xfree and wav
332- Improved package Require lines
333- Added mp3encode (lame based) to the SPEC
334
335* Wed Dec 12 2001 Christian Schaller <Uraeus@linuxrising.org>
336- Thomas merged mpeg plugins into one
337* Sat Dec 08 2001 Christian Schaller <Uraeus@linuxrising.org>
338- More minor cleanups including some fixed descriptions from Andrew Mitchell
339
340* Fri Dec 07 2001 Christian Schaller <Uraeus@linuxrising.org>
341- Added logging to the make statement
342
343* Wed Dec 05 2001 Christian Schaller <Uraeus@linuxrising.org>
344- Updated in preparation for 0.3.0 release
345
346* Fri Jun 29 2001 Christian Schaller <Uraeus@linuxrising.org>
347- Updated for 0.2.1 release
348- Split out the GUI packages into their own RPM
349- added new plugins (FLAC, festival, quicktime etc.)
350
351* Sat Jun 09 2001 Christian Schaller <Uraeus@linuxrising.org>
352- Visualisation plugins bundled out togheter
353- Moved files sections up close to their respective descriptions
354
355* Sat Jun 02 2001 Christian Schaller <Uraeus@linuxrising.org>
356- Split the package into separate RPMS,
357  putting most plugins out by themselves.
358
359* Fri Jun 01 2001 Christian Schaller <Uraeus@linuxrising.org>
360- Updated with change suggestions from Dennis Bjorklund
361
362* Tue Jan 09 2001 Erik Walthinsen <omega@cse.ogi.edu>
363- updated to build -devel package as well
364
365* Sun Jan 30 2000 Erik Walthinsen <omega@cse.ogi.edu>
366- first draft of spec file
367
Note: See TracBrowser for help on using the repository browser.