source: trunk/third/libgtop/libgtop.spec @ 18532

Revision 18532, 3.1 KB checked in by ghudson, 21 years ago (diff)
This commit was generated by cvs2svn to compensate for changes in r18531, which included commits to RCS files with non-trunk default branches.
Line 
1# Note that this is NOT a relocatable package
2%define ver      2.0.1
3%define  RELEASE SNAP
4%define  rel     %{?CUSTOM_RELEASE} %{!?CUSTOM_RELEASE:%RELEASE}
5%define prefix   /usr
6
7Summary: LibGTop library
8Name: libgtop
9Version: %ver
10Release: %rel
11Copyright: LGPL
12Group: X11/Libraries
13Source: ftp://ftp.gnome.org/pub/GNOME/sources/libgtop/libgtop-%{ver}.tar.gz
14BuildRoot: /tmp/libgtop-root
15Packager: Martin Baulig <martin@home-of-linux.org>
16URL: http://www.home-of-linux.org/gnome/libgtop/
17Prereq: /sbin/install-info
18Docdir: %{prefix}/doc
19
20%description
21
22A library that fetches information about the running system such as
23cpu and memory usage, active processes etc.
24
25On Linux systems, these information are taken directly from the /proc
26filesystem while on other systems a server is used to read those
27information from /dev/kmem or whatever.
28
29%package devel
30Summary: Libraries, includes, etc to develop LibGTop applications
31Group: X11/libraries
32Requires: libgtop
33
34%description devel
35Libraries, include files, etc you can use to develop GNOME applications.
36
37%package examples
38Summary: Examples for LibGTop
39Group: X11/libraries
40Requires: libgtop
41
42%description examples
43Examples for LibGTop.
44
45
46%changelog
47
48* Tue Aug 19 1998 Martin Baulig <martin@home-of-linux.org>
49
50- released LibGTop 0.25.0
51
52* Sun Aug 16 1998 Martin Baulig <martin@home-of-linux.org>
53
54- first version of the RPM
55
56%prep
57%setup
58
59%build
60# Needed for snapshot releases.
61if [ ! -f configure ]; then
62  CFLAGS="$RPM_OPT_FLAGS" ./autogen.sh --prefix=%prefix --without-linux-table --with-libgtop-inodedb --with-libgtop-examples --with-libgtop-guile --with-libgtop-smp
63else
64%ifarch alpha
65  CFLAGS="$RPM_OPT_FLAGS" ./configure --host=alpha-redhat-linux --prefix=%prefix --without-linux-table --with-libgtop-inodedb --with-libgtop-examples --with-libgtop-guile --with-libgtop-smp
66%else
67  CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%prefix --without-linux-table --with-libgtop-inodedb --with-libgtop-examples --with-libgtop-guile --with-libgtop-smp
68%endif
69fi
70
71if [ "$SMP" != "" ]; then
72  (make "MAKE=make -k -j $SMP"; exit 0)
73  make
74else
75  make
76fi
77
78%install
79rm -rf $RPM_BUILD_ROOT
80
81make prefix=$RPM_BUILD_ROOT%{prefix} install
82
83#
84# msf - remove these as they are really supposed to come from gnome-libs
85#
86# martin - don't remove since they are no longer installed if build
87#          with GNOME
88#
89# rm -f $RPM_BUILD_ROOT/%{prefix}/lib/libgnomesupport.a
90# rm -f $RPM_BUILD_ROOT/%{prefix}/lib/libgnomesupport.la
91# rm -f $RPM_BUILD_ROOT/%{prefix}/lib/libgnomesupport.so.0
92# rm -f $RPM_BUILD_ROOT/%{prefix}/lib/libgnomesupport.so.0.0.0
93
94rm -fr $RPM_BUILD_ROOT/%{prefix}/include/libgtop
95
96%clean
97rm -rf $RPM_BUILD_ROOT
98
99%post -p /sbin/ldconfig
100
101%postun -p /sbin/ldconfig
102
103%files
104%defattr(-, root, root)
105
106%doc RELNOTES-0.25 RELNOTES-1.0 AUTHORS ChangeLog NEWS README
107%doc TODO NEWS.old copyright.txt
108%doc src/inodedb/README.inodedb
109
110%{prefix}/lib/lib*.so.*
111%{prefix}/share/*
112%{prefix}/bin/*
113
114%files devel
115%defattr(-, root, root)
116
117%{prefix}/lib/lib*.so
118%{prefix}/lib/*a
119%{prefix}/lib/*.sh
120%{prefix}/lib/*.def
121%{prefix}/include/*
122
123%files examples
124%defattr(-,root,root)
125
126%{prefix}/libexec/libgtop
Note: See TracBrowser for help on using the repository browser.