source: config-package-dev/examples/debathena-bin-example-1.1/debian/rules @ 5670913

Revision 5670913, 1.0 KB checked in by Tim Abbott <tabbott@…>, 16 years ago (diff)
Improve config-package-dev documentation and examples. git-svn-id: svn+ssh://svn.mit.edu/athena/trunk/debathena/debathena/config-package-dev@23076 728af825-273c-0410-89f9-f7d3b574a069
  • Property mode set to 100755
Line 
1#!/usr/bin/make -f
2
3DEB_DIVERT_EXTENSION = .debathena
4# Install wrapper scripts for /usr/bin/elinks and /usr/bin/less
5DEB_DIVERT_FILES_debathena-bin-example += \
6        /usr/bin/less.debathena
7
8# If these had materially different behavior from the original
9# versions, one might divert the man pages as well
10DEB_DIVERT_FILES_debathena-bin-example += /usr/share/man/man1/less.debathena.1.gz
11
12# This isn't config-package-dev specific, but we may want to install symlinks instead.
13DEB_DH_LINK_debathena-bin-example += \
14        /usr/share/man/man1/less.debathena-orig.1.gz /usr/share/man/man1/less.debathena.1.gz
15
16# Remove elinks diversion on upgrade from version(s) prior to 1.1
17DEB_UNDIVERT_FILES_debathena-bin-example += /usr/bin/elinks.debathena
18DEB_UNDIVERT_VERSION_/usr/bin/elinks.debathena = 1.1
19# and the man page
20DEB_UNDIVERT_FILES_debathena-bin-example += /usr/share/man/man1/elinks.debathena.1.gz
21DEB_UNDIVERT_VERSION_/usr/share/man/man1/elinks.debathena.1.gz = 1.1
22
23include /usr/share/cdbs/1/rules/debhelper.mk
24include /usr/share/cdbs/1/rules/config-package.mk
Note: See TracBrowser for help on using the repository browser.