source: trunk/athena/bin/grenew/debian/rules @ 24042

Revision 24042, 506 bytes checked in by broder, 15 years ago (diff)
In grenew: * Support building on systems where krb5 no longer comes with krb4. (Trac: #380)
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3DEB_AUTO_UPDATE_AUTOCONF = 2.50
4include /usr/share/cdbs/1/rules/debhelper.mk
5include /usr/share/cdbs/1/class/autotools.mk
6
7KRB5_VERSION = $(shell dpkg-query --showformat='$${Version}' --show libkrb5-dev)
8
9ifeq ($(shell dpkg --compare-versions $(KRB5_VERSION) '<<' '1.7~' && echo y),y)
10        DEB_CONFIGURE_EXTRA_FLAGS += --with-krb4=$(shell krb4-config --prefix krb4)
11else
12        DEB_CONFIGURE_EXTRA_FLAGS += --without-krb4
13endif
14
15DEB_CONFIGURE_EXTRA_FLAGS += --with-krb5
16
17clean::
18        rm -f configure
Note: See TracBrowser for help on using the repository browser.