source: trunk/athena/lib/athdir/debian/rules @ 24615

Revision 24615, 1021 bytes checked in by broder, 14 years ago (diff)
In libathdir, DEB_AUTO_UPDATE_LIBTOOL requires DEB_AUTO_UPDATE_ACLOCAL.
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3DEB_AUTO_UPDATE_AUTOCONF = 2.50
4DEB_AUTO_UPDATE_ACLOCAL = 1.9
5DEB_AUTO_UPDATE_LIBTOOL = pre
6
7include /usr/share/cdbs/1/rules/debhelper.mk
8include /usr/share/cdbs/1/class/autotools.mk
9
10DEB_DH_INSTALL_SOURCEDIR = $(DEB_DESTDIR)
11
12debian/stamp-autotools-files: aclocal.m4 config.guess config.sub install-sh missing
13aclocal.m4:
14        aclocal-1.9
15config.guess config.sub:
16        cp /usr/share/misc/$@ $@
17install-sh missing:
18        -automake-1.9 --foreign --add-missing
19
20common-configure-arch:: verify-versions
21verify-versions: debian/stamp-autotools-files
22        if ! $(DEB_CONFIGURE_SCRIPT) --version | \
23            grep -Fqx "libathdir configure $(DEB_UPSTREAM_VERSION)"; then \
24            echo "E: Debian and upstream version numbers don't match." >&2 ; \
25            echo "E: Did you forget to update the version number in configure.ac?" >&2 ; \
26            exit 1 ; \
27        fi
28
29export ATHENA_SYS=$(shell machtype -S)
30export ATHENA_HOSTTYPE=$(shell machtype)
31
32clean::
33        rm -f configure aclocal.m4 install-sh missing libtool ltmain.sh config.guess config.sub
Note: See TracBrowser for help on using the repository browser.