source: trunk/athena/lib/locker/debian/rules @ 24551

Revision 24551, 784 bytes checked in by broder, 14 years ago (diff)
In locker: * Use debathena-aclocal instead of the Athena aclocal.m4 file.
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3DEB_AUTO_UPDATE_AUTOCONF = 2.50
4DEB_AUTO_UPDATE_ACLOCAL = 1.9
5
6include /usr/share/cdbs/1/rules/debhelper.mk
7include /usr/share/cdbs/1/class/autotools.mk
8
9debian/stamp-autotools-files: aclocal.m4 config.guess config.sub install-sh missing
10aclocal.m4:
11        touch $@
12config.guess config.sub:
13        cp /usr/share/misc/$@ $@
14install-sh missing:
15        -automake-1.9 --foreign --add-missing
16
17DEB_CONFIGURE_EXTRA_FLAGS += --with-afs=/usr --disable-nfs --with-krb5 --with-hesiod
18DEB_DH_INSTALL_SOURCEDIR = $(DEB_DESTDIR)
19DEB_UPDATE_RCD_PARAMS = "start 65 S ."
20
21ifeq ($(DEB_BUILD_ARCH),amd64)
22    CFLAGS += -fPIC
23endif
24
25common-install-indep::
26        dh_install -pdebathena-liblocker debian/attach.conf etc/athena/
27
28clean::
29        rm -f configure aclocal.m4 install-sh missing config.guess config.sub
Note: See TracBrowser for help on using the repository browser.