source: trunk/debathena/config/athena-chroot/debian/debathena-athena-chroot.postinst @ 22908

Revision 22908, 1.1 KB checked in by tabbott, 16 years ago (diff)
debathena-athena-chroot: various bugfixes * debian/lastlog.debathena: Add -- to command line. * installer/install: Setup NSS in chroot sloppily. * schroot/exec.d: Remove passwd file copying code. * schroot/schroot.conf.debathena: set personality to linux32.
Line 
1#!/bin/sh
2# postinst script for #PACKAGE#
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20#DEBHELPER#
21
22case "$1" in
23    configure)
24        # schroot doesn't deal with symlinks; see bug #476332
25        if [ -z "$2" ]; then
26            rm -f /etc/schroot/schroot.conf
27            ln /etc/schroot/schroot.conf.debathena /etc/schroot/schroot.conf
28        fi
29    ;;
30
31    abort-upgrade|abort-remove|abort-deconfigure)
32    ;;
33
34    *)
35        echo "postinst called with unknown argument \`$1'" >&2
36        exit 1
37    ;;
38esac
39
40# dh_installdeb will replace this with shell code automatically
41# generated by other debhelper scripts.
42
43exit 0
44
45
Note: See TracBrowser for help on using the repository browser.