source: trunk/debathena/config/auto-update/debian/debathena-auto-update.postinst @ 24523

Revision 24523, 1.2 KB checked in by jdreed, 14 years ago (diff)
Commit log for #PACKAGE#
Line 
1#!/bin/sh
2# postinst script for debathena-auto-update
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20
21case "$1" in
22    configure)
23        # Nuke /var/lib/athena-update-status on 1.18,
24        # since we changed its format. It will be created
25        # at the next auto update
26        if dpkg --compare-versions "$2" lt 1.18~ &&
27            [ -f /var/lib/athena-update-status ]; then
28            rm /var/lib/athena-update-status
29        fi
30       
31    ;;
32
33    abort-upgrade|abort-remove|abort-deconfigure)
34    ;;
35
36    *)
37        echo "postinst called with unknown argument \`$1'" >&2
38        exit 1
39    ;;
40esac
41
42# dh_installdeb will replace this with shell code automatically
43# generated by other debhelper scripts.
44
45#DEBHELPER#
46
47exit 0
Note: See TracBrowser for help on using the repository browser.