source: trunk/debathena/config/dns-config/debian/debathena-dns-config.postinst @ 25723

Revision 25723, 1.4 KB checked in by jdreed, 12 years ago (diff)
In dns-config: * Do not build for Hardy anymore * Ship a sample resolv.conf for MIT, and use it if we end up with no nameservers configured at the end of the postinst
Line 
1#!/bin/sh
2# postinst script for debathena-dns-config
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20
21#DEBHELPER#
22
23case "$1" in
24    configure)
25        if hash invoke-rc.d 2>/dev/null; then
26            invoke-rc.d dnsmasq restart || true
27            invoke-rc.d debathena-dns-config restart
28        else
29            /etc/init.d/dnsmasq restart || true
30            /etc/init.d/debathena-dns-config restart
31        fi
32        if ! grep -q '^nameserver' /etc/resolv.conf; then
33            # Don't leave people without a nameserver
34            cat /usr/share/debathena-dns-config/mit-resolv-conf | /sbin/resolvconf -a lo.dns-config
35        fi
36        if [ -x /usr/share/update-notifier/notify-reboot-required ]; then
37            /usr/share/update-notifier/notify-reboot-required
38        fi
39    ;;
40
41    abort-upgrade|abort-remove|abort-deconfigure)
42    ;;
43
44    *)
45        echo "postinst called with unknown argument \`$1'" >&2
46        exit 1
47    ;;
48esac
Note: See TracBrowser for help on using the repository browser.