source: trunk/debathena/config/gdm-config/debian/debathena-gdm-config.postinst @ 23267

Revision 23267, 1.1 KB checked in by amb, 16 years ago (diff)
Modified the gdm reload to be conditional on gdm running.
Line 
1#!/bin/sh
2# postinst script for debathena-gdm-config
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20
21case "$1" in
22    configure)
23        if test -f /var/run/gdm.pid ; then
24            if hash invoke-rc.d 2>/dev/null; then
25                invoke-rc.d gdm reload
26                else
27                /etc/init.d/gdm reload
28            fi
29        fi
30    ;;
31
32    abort-upgrade|abort-remove|abort-deconfigure)
33    ;;
34
35    *)
36        echo "postinst called with unknown argument \`$1'" >&2
37        exit 1
38    ;;
39esac
40
41# dh_installdeb will replace this with shell code automatically
42# generated by other debhelper scripts.
43
44#DEBHELPER#
45
46exit 0
47
48
Note: See TracBrowser for help on using the repository browser.