source: trunk/debathena/config/gdm-config/debian/debathena-gdm-config.postinst @ 24063

Revision 24063, 1.5 KB checked in by geofft, 15 years ago (diff)
In gdm-config: * Don't make errors in reloading gdm's configuration fatal for upgrading the package.
Line 
1#!/bin/sh
2# postinst script for debathena-gdm-config
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20
21case "$1" in
22    configure)
23        if test -f /var/run/gdm.pid ; then
24            if hash invoke-rc.d 2>/dev/null; then
25                invoke-rc.d gdm reload || true
26                else
27                /etc/init.d/gdm reload || true
28            fi
29        fi
30        # We don't actually want the "unknown metapackage" file, but it
31        # needs to be present in case you have debathena-gdm-config and
32        # nothing else, so give it priority 0.
33        update-alternatives --install \
34            /usr/share/gdm/themes/debathena/metapackage.svg \
35            debathena-metapackage.svg \
36            /usr/share/gdm/themes/debathena/metapackage-unknown.svg \
37            0
38    ;;
39
40    abort-upgrade|abort-remove|abort-deconfigure)
41    ;;
42
43    *)
44        echo "postinst called with unknown argument \`$1'" >&2
45        exit 1
46    ;;
47esac
48
49# dh_installdeb will replace this with shell code automatically
50# generated by other debhelper scripts.
51
52#DEBHELPER#
53
54exit 0
55
56
Note: See TracBrowser for help on using the repository browser.