source: trunk/debathena/config/kerberos-config/debian/debathena-kerberos-config.postinst @ 25903

Revision 25903, 1.4 KB checked in by jdreed, 11 years ago (diff)
In kerberos-config: * Punt all the old cleanup code and divert.sh from postinst; simply undivert/unhide as necessary
  • Property svn:executable set to *
Line 
1#!/bin/sh
2# postinst script for debathena-kerberos-config
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20# dh_installdeb will replace this with shell code automatically
21# generated by other debhelper scripts.
22
23#DEBHELPER#
24
25case "$1" in
26    configure)
27        if dpkg-query -f '${Conffiles}\n' -W debathena-kerberos-config | grep '/etc/apparmor.d/usr.sbin.cups.debathena' | awk '{ print $2"  "$1 }' | md5sum -c >/dev/null 2>&1; then
28            rm -f /etc/apparmor.d/usr.sbin.cups.debathena
29        fi
30
31        if dpkg --compare-versions "$2" lt-nl "1.10~" && \
32            hash apparmor_status 2>/dev/null && \
33            apparmor_status --enabled; then
34            if hash invoke-rc.d 2>/dev/null; then
35                invoke-rc.d apparmor reload
36            else
37                /etc/init.d/apparmor reload
38            fi
39        fi
40    ;;
41
42    abort-upgrade|abort-remove|abort-deconfigure)
43    ;;
44
45    *)
46        echo "postinst called with unknown argument \`$1'" >&2
47        exit 1
48    ;;
49esac
50
51exit 0
52
53
Note: See TracBrowser for help on using the repository browser.