source: trunk/debathena/config/printing-config/debian/rules @ 25746

Revision 25746, 1.1 KB checked in by jdreed, 12 years ago (diff)
In printing-config: * Remove DEB_UNDIVERT_VERSION, unneeded as of c-p-d 4.12 (and build-dep on 4.12) * Drop our english-to-english translation added in version 1.10 because upstream (https://fedorahosted.org/system-config-printer/ticket/181) fixed this years ago.
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3DEB_PYTHON_SYSTEM = pysupport
4
5DEB_DIVERT_EXTENSION = .debathena
6
7DEB_DIVERT_FILES_debathena-printing-config += \
8        /usr/bin/lp.debathena \
9        /usr/bin/lpq.debathena \
10        /usr/bin/lpr.debathena \
11        /usr/bin/lprm.debathena \
12        \
13        /usr/share/man/man1/lp.debathena.1.gz \
14        /usr/share/man/man1/lpq.debathena.1.gz \
15        /usr/share/man/man1/lpr.debathena.1.gz \
16        /usr/share/man/man1/lprm.debathena.1.gz \
17
18DEB_UNDIVERT_FILES_debathena-printing-config += \
19        /usr/bin/cancel.debathena \
20        /usr/sbin/lpc.debathena \
21        /usr/share/man/man1/cancel.debathena.1.gz \
22        /usr/share/man/man8/lpc.debathena.8.gz
23
24include /usr/share/cdbs/1/rules/debhelper.mk
25include /usr/share/cdbs/1/rules/config-package.mk
26include /usr/share/cdbs/1/class/python-distutils.mk
27
28ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
29common-build-arch common-build-indep:: $(addprefix python-check-stamp-, $(cdbs_python_build_versions))
30python-check-stamp-%: python-build-stamp-%
31        $(call cdbs_python_binary,python$(cdbs_python_compile_version)) setup.py nosetests
32        touch $@
33
34clean::
35        rm -rf python-check-stamp-* mox-*.egg .coverage
36endif
37
38clean::
39        rm -rf debathena.printing.egg-info
Note: See TracBrowser for help on using the repository browser.