source: trunk/debathena/config/reactivate/debian/debathena-reactivate.postinst @ 24028

Revision 24028, 2.6 KB checked in by broder, 15 years ago (diff)
In order to let gdm-config add the new diversions at approximately the same time that reactivate is dropping them, we can't use DEB_UNDIVERT_FILES, so write some more clever code of our own instead. (Because gdm-config's postinst was triggering before reactivate's, it was to trying and create the diversions before reactivate had removed them.)
  • Property svn:executable set to *
Line 
1#!/bin/sh
2# postinst script for #PACKAGE#
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20
21package=debathena-reactivate
22ours=.debathena
23theirs=.debathena-orig
24
25undivert_unlink_symlink()
26{
27    file="$1"
28    ourfile="$2"
29    theirfile="$3"
30    if [ ! -L "$file" ] || \
31        [ "$(readlink "$file")" != "$(basename "$ourfile")" -a \
32          "$(readlink "$file")" != "$(basename "$theirfile")" ]; then
33        echo "*** OMINOUS WARNING ***: $file is not linked to either $(basename "$ourfile") or $(basename "$theirfile")" >&2
34    else
35        rm -f "$file"
36    fi
37}
38
39undivert_unlink_divert()
40{
41    file="$1"
42    if [ ! -L "$file" ] && [ ! -e "$file" ]; then
43        dpkg-divert --remove --rename --package "$package" "$file"
44    else
45        echo "Not removing diversion of $file by $package" >&2
46    fi
47}
48
49undivert_unlink()
50{
51    prefix=$1
52    suffix=$2
53
54    file=$prefix$suffix
55    ourfile=$prefix$ours$suffix
56    theirfile=$prefix$theirs$suffix
57
58    undivert_unlink_symlink "$file" "$ourfile" "$theirfile"
59    undivert_unlink_divert "$file" "$package"
60}
61
62cleanup_old_diversion() {
63    file="$1"
64    if dpkg-divert --list "${file}" | grep -Fxq "diversion of ${file} to ${file}${theirs} by ${package}"; then
65        undivert_unlink "$file"
66    fi
67}
68
69
70case "$1" in
71    configure)
72        # Users logging in will be added to several different
73        # groups. Make sure they all exist.
74        for group in $(sed -ne 's/^addgroups="\(.*\)"/\1/p' /usr/sbin/athena-login-snapshot); do
75            getent group "$group" >/dev/null || addgroup --system "$group"
76        done
77        cat >>/etc/sudoers <<EOF
78### BEGIN debathena-reactivate
79Defaults:%admin lecture_file=/etc/athena/sudo-warning, lecture=once
80### END debathena-reactivate
81EOF
82
83        cleanup_old_diversion /etc/gdm/PreSession/Default
84        cleanup_old_diversion /etc/gdm/PostSession/Default
85
86    ;;
87
88    abort-upgrade|abort-remove|abort-deconfigure)
89    ;;
90
91    *)
92        echo "postinst called with unknown argument \`$1'" >&2
93        exit 1
94    ;;
95esac
96
97# dh_installdeb will replace this with shell code automatically
98# generated by other debhelper scripts.
99
100#DEBHELPER#
101
102exit 0
103
104
Note: See TracBrowser for help on using the repository browser.