source: trunk/debathena/config/reactivate/debian/debathena-reactivate.postinst @ 24528

Revision 24528, 3.0 KB checked in by jdreed, 14 years ago (diff)
Fix package name in maintainer scripts in multiple packages
  • Property svn:executable set to *
Line 
1#!/bin/sh
2# postinst script for debathena-reactivate
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20
21package=debathena-reactivate
22ours=.debathena
23theirs=.debathena-orig
24
25undivert_unlink_symlink()
26{
27    file="$1"
28    ourfile="$2"
29    theirfile="$3"
30    if [ ! -L "$file" ] || \
31        [ "$(readlink "$file")" != "$(basename "$ourfile")" -a \
32          "$(readlink "$file")" != "$(basename "$theirfile")" ]; then
33        echo "*** OMINOUS WARNING ***: $file is not linked to either $(basename "$ourfile") or $(basename "$theirfile")" >&2
34    else
35        rm -f "$file"
36    fi
37}
38
39undivert_unlink_divert()
40{
41    file="$1"
42    if [ ! -L "$file" ] && [ ! -e "$file" ]; then
43        dpkg-divert --remove --rename --package "$package" "$file"
44    else
45        echo "Not removing diversion of $file by $package" >&2
46    fi
47}
48
49undivert_unlink()
50{
51    prefix=$1
52    suffix=$2
53
54    file=$prefix$suffix
55    ourfile=$prefix$ours$suffix
56    theirfile=$prefix$theirs$suffix
57
58    undivert_unlink_symlink "$file" "$ourfile" "$theirfile"
59    undivert_unlink_divert "$file" "$package"
60}
61
62cleanup_old_diversion() {
63    file="$1"
64    if dpkg-divert --list "${file}" | grep -Fxq "diversion of ${file} to ${file}${theirs} by ${package}"; then
65        undivert_unlink "$file"
66    fi
67}
68
69. /usr/lib/debathena-cupsys-config/restart-cups.sh
70
71
72case "$1" in
73    configure)
74        # Users logging in will be added to several different
75        # groups. Make sure they all exist.
76        for group in $(sed -ne 's/^addgroups="\(.*\)"/\1/p' /etc/gdm/Xsession.debathena); do
77            getent group "$group" >/dev/null || addgroup --system "$group"
78        done
79        cat >>/etc/sudoers <<EOF
80### BEGIN debathena-reactivate
81Defaults lecture_file=/etc/athena/sudo-error, lecture=always
82Defaults:%admin lecture_file=/etc/athena/sudo-warning, lecture=once
83### END debathena-reactivate
84EOF
85
86        if dpkg --compare-versions "$2" lt 1.25.5~ && \
87            dpkg --compare-versions "$2" ge 1.25.2; then
88            ln -nsf su.debathena /etc/pam.d/su
89        fi
90
91        cleanup_old_diversion /etc/gdm/PreSession/Default
92        cleanup_old_diversion /etc/gdm/PostSession/Default
93
94        if dpkg --compare-versions "$2" lt 2.0.9~ && \
95            [ -x /usr/share/update-notifier/notify-reboot-required ]; then
96            /usr/share/update-notifier/notify-reboot-required
97        fi
98
99        # Make printing suck less
100        restart_cups
101    ;;
102
103    abort-upgrade|abort-remove|abort-deconfigure)
104    ;;
105
106    *)
107        echo "postinst called with unknown argument \`$1'" >&2
108        exit 1
109    ;;
110esac
111
112# dh_installdeb will replace this with shell code automatically
113# generated by other debhelper scripts.
114
115#DEBHELPER#
116
117exit 0
118
119
Note: See TracBrowser for help on using the repository browser.