source: trunk/debathena/config/reactivate/debian/rules @ 25671

Revision 25671, 1.1 KB checked in by jdreed, 12 years ago (diff)
In reactivate: * Ship a session wrapper that runs initgroups(3) and stop abusing sudo (Trac: #928) * Stop depending on kexec-tools, which hasn't been needed since 2.0.25 * Wrap Depends line for easier reading
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3DEB_DIVERT_EXTENSION = .debathena
4DEB_DIVERT_FILES_debathena-reactivate += \
5        /etc/gdm/Xsession.debathena \
6        /usr/sbin/lightdm-session.debathena
7DEB_TRANSFORM_FILES_debathena-reactivate += \
8        /etc/pam.d/su.debathena \
9        /etc/default/schroot.debathena \
10        /etc/pam.d/schroot.debathena \
11        /etc/dbus-1/system.conf.debathena
12DEB_REMOVE_FILES_debathena-reactivate += \
13        /etc/xdg/autostart/jockey-gtk.desktop \
14        /etc/xdg/autostart/update-notifier.desktop \
15        /etc/xdg/autostart/nm-applet.desktop
16
17DEB_UNDIVERT_FILES_debathena-reactivate += \
18        /etc/pam.d/sudo.debathena
19DEB_UNDIVERT_VERSION_/etc/pam.d/sudo.debathena = 1.25.2~
20
21DEB_TRANSFORM_SCRIPT_/etc/default/schroot.debathena = \
22        debian/transform_schroot_defaults
23DEB_TRANSFORM_SCRIPT_/etc/pam.d/schroot.debathena = \
24        debian/transform_schroot_pam
25
26# The wrapper does in fact need to be setuid
27DEB_FIXPERMS_EXCLUDE += \
28    usr/lib/debathena-reactivate/session-wrapper
29
30include /usr/share/cdbs/1/rules/debhelper.mk
31include /usr/share/cdbs/1/class/makefile.mk
32include /usr/share/cdbs/1/rules/config-package.mk
33
34DEB_MAKE_INSTALL_TARGET = install DESTDIR=$(DEB_DESTDIR)
Note: See TracBrowser for help on using the repository browser.