source: trunk/debathena/config/syslog-config/debian/rules @ 24246

Revision 24246, 606 bytes checked in by broder, 14 years ago (diff)
Update the postinst for dealing with rsyslog.
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3DEB_DIVERT_EXTENSION = .debathena
4
5ifneq ($(wildcard /etc/syslog.conf),)
6    DAEMON = sysklogd
7    DEB_TRANSFORM_FILES_debathena-syslog-config += \
8        /etc/syslog.conf.debathena
9else ifneq ($(wildcard /etc/rsyslog.d),)
10    DAEMON = rsyslog
11else
12    # If you change this, be sure to update the postinst, too
13    $(error Unknown default syslog daemon.)
14endif
15
16include /usr/share/cdbs/1/rules/debhelper.mk
17include /usr/share/cdbs/1/rules/config-package.mk
18
19ifeq ($(DAEMON),rsyslog)
20    install/debathena-syslog-config::
21        dh_install debian/50-debathena-syslog-config.conf etc/rsyslog.d
22endif
Note: See TracBrowser for help on using the repository browser.