source: trunk/debathena/config/tex-config/debian/debathena-tex-config.postinst @ 23670

Revision 23670, 991 bytes checked in by broder, 15 years ago (diff)
In tex-config, move debhelper substitutions to the beginning of the maintainer scripts so that diversions are in place when fmtutil-sys is run.
  • Property svn:executable set to *
Line 
1#!/bin/sh
2# postinst script for #PACKAGE#
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# dh_installdeb will replace this with shell code automatically
9# generated by other debhelper scripts.
10
11#DEBHELPER#
12
13# summary of how this script can be called:
14#        * <postinst> `configure' <most-recently-configured-version>
15#        * <old-postinst> `abort-upgrade' <new version>
16#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
17#          <new-version>
18#        * <postinst> `abort-remove'
19#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
20#          <failed-install-package> <version> `removing'
21#          <conflicting-package> <version>
22# for details, see http://www.debian.org/doc/debian-policy/ or
23# the debian-policy package
24
25
26case "$1" in
27    configure)
28        fmtutil-sys --refresh
29    ;;
30
31    abort-upgrade|abort-remove|abort-deconfigure)
32    ;;
33
34    *)
35        echo "postinst called with unknown argument \`$1'" >&2
36        exit 1
37    ;;
38esac
39
40exit 0
41
42
Note: See TracBrowser for help on using the repository browser.