source: trunk/debathena/config/zephyr-config/debian/debathena-zephyr-config.postinst @ 23970

Revision 23970, 1.0 KB checked in by geofft, 15 years ago (diff)
In zephyr-config: * Don't fail to configure the package if networking is unavailable and thus zhm can't restart.
Line 
1#!/bin/sh
2# postinst script for debathena-zephyr-config
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20
21#DEBHELPER#
22
23case "$1" in
24    configure)
25        start-stop-daemon --oknodo --stop --retry 5 --quiet --pidfile \
26            /var/run/zhm.pid --name zhm
27        if hash invoke-rc.d; then
28            invoke-rc.d zhm restart || :
29        else
30            /etc/init.d/zhm restart || :
31        fi
32    ;;
33
34    abort-upgrade|abort-remove|abort-deconfigure)
35    ;;
36
37    *)
38        echo "postinst called with unknown argument \`$1'" >&2
39        exit 1
40    ;;
41esac
Note: See TracBrowser for help on using the repository browser.