source: trunk/debathena/debathena/archive-keyring/debian/debathena-archive-keyring.postinst @ 24529

Revision 24529, 1.3 KB checked in by jdreed, 14 years ago (diff)
Fix package name in maintainer scripts in multiple packages
  • Property svn:executable set to *
Line 
1#!/bin/sh
2# postinst script for debathena-archive-keyring
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20case "$1" in
21    configure)
22        if hash apt-key >/dev/null 2>&1; then
23            apt-key add /usr/share/keyrings/debathena-archive-keyring.gpg
24            if apt-key list | grep -q A2DA1A6C; then
25                apt-key del A2DA1A6C
26            fi
27            if apt-key list | grep -q 997D6B23; then
28                apt-key del 997D6B23
29            fi
30        fi
31    ;;
32
33    abort-upgrade|abort-remove|abort-deconfigure)
34    ;;
35
36    *)
37        echo "postinst called with unknown argument \`$1'" >&2
38        exit 1
39    ;;
40esac
41
42# dh_installdeb will replace this with shell code automatically
43# generated by other debhelper scripts.
44
45#DEBHELPER#
46
47exit 0
Note: See TracBrowser for help on using the repository browser.