source: trunk/debathena/debathena/debathena-afuse-automounter/debian/debathena-afuse-automounter.postinst @ 22945

Revision 22945, 1.4 KB checked in by tabbott, 16 years ago (diff)
In debathena-afuse-automounter: * Restart afuse on upgrades.
Line 
1#!/bin/sh
2# postinst script for #PACKAGE#
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20
21case "$1" in
22    configure)
23        # Need to be clever with removing debathena-autofs-config.
24        if pgrep -f "/usr/sbin/automount --pid-file=/var/run/autofs/_mit.pid .* /mit hesiod" > /dev/null; then
25            if [ -n "$2" ]; then
26                echo "This is an upgrade from version $2; not restarting afuse automounter"
27            else
28                echo "Upgrade from autofs which has failed to stop; not starting afuse automounter"
29            fi
30            update-rc.d debathena-afuse-automounter defaults 26 17 >/dev/null
31        else
32            #DEBHELPER#
33        fi
34        ;;
35
36    abort-upgrade|abort-remove|abort-deconfigure)
37    ;;
38
39    *)
40        echo "postinst called with unknown argument \`$1'" >&2
41        exit 1
42    ;;
43esac
44
45# dh_installdeb will replace this with shell code automatically
46# generated by other debhelper scripts.
47
48exit 0
49
50
Note: See TracBrowser for help on using the repository browser.