source: trunk/debathena/debathena/dotfiles/debian/debathena-dotfiles.postinst @ 23828

Revision 23828, 1.3 KB checked in by andersk, 15 years ago (diff)
In dotfiles: * New upstream version, since the previous change modified files outside debian/. * Ensure /var/run/athena-sessions exists in the postinst, in case the system was rebooted and /var/run was cleaned between package unpacking and configuration.
Line 
1#!/bin/sh
2# postinst script for debathena-dotfiles
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20
21case "$1" in
22    configure)
23        mkdir -p /var/run/athena-sessions
24        if ! dpkg-statoverride --list /var/run/athena-sessions >/dev/null; then
25            chmod a=rwx,u+t /var/run/athena-sessions
26        fi
27
28        if dpkg --compare-versions "$2" lt 10.0.9-0debathena2; then
29            add-shell /bin/athena/bash /bin/athena/tcsh
30        fi
31    ;;
32
33    abort-upgrade|abort-remove|abort-deconfigure)
34    ;;
35
36    *)
37        echo "postinst called with unknown argument \`$1'" >&2
38        exit 1
39    ;;
40esac
41
42# dh_installdeb will replace this with shell code automatically
43# generated by other debhelper scripts.
44
45#DEBHELPER#
46
47exit 0
48
49
Note: See TracBrowser for help on using the repository browser.