source: trunk/debathena/debathena/dotfiles/debian/rules @ 24225

Revision 24225, 668 bytes checked in by geofft, 14 years ago (diff)
In dotfiles: * Install Lintian overrides for non-standard-dir-in-usr and file-in-unusual-dir for /usr/prototype_user, which is a legacy pathname we need to support indefinitely.
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3include /usr/share/cdbs/1/rules/debhelper.mk
4include /usr/share/cdbs/1/class/makefile.mk
5
6OS = linux
7ATHENA_MAJOR_VERSION = 9
8ATHENA_MINOR_VERSION = 4
9
10DEB_MAKE_INSTALL_TARGET = install DESTDIR=$(DEB_DESTDIR)
11DEB_MAKE_INVOKE += OS=$(OS) ATHENA_MAJOR_VERSION=$(ATHENA_MAJOR_VERSION) ATHENA_MINOR_VERSION=$(ATHENA_MINOR_VERSION)
12DEB_DESTDIR = $(CURDIR)/debian/tmp/
13DEB_DH_INSTALL_SOURCEDIR = $(DEB_DESTDIR)
14DEB_UPDATE_RCD_PARAMS = "start 65 S ."
15
16common-build-indep::
17        mkdir -p $(DEB_DESTDIR)/usr/share/lintian/overrides
18        cp $(CURDIR)/debian/lintian/debathena-dotfiles $(DEB_DESTDIR)/usr/share/lintian/overrides/
19
20clean::
21        rm -f gnome/athena.schemas
Note: See TracBrowser for help on using the repository browser.