source: trunk/debathena/debathena/larvnet/debian/debathena-larvnet.postinst @ 23128

Revision 23128, 1.2 KB checked in by ghudson, 16 years ago (diff)
In larvnet: * Use a better test for the workstation's busy state. * Run busyd as nobody.
Line 
1#!/bin/sh
2# postinst script for debathena-larvnet
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20
21case "$1" in
22    configure)
23        if ! grep -q '^busypoll[[:space:]]' /etc/services; then
24            cat <<EOF >>/etc/services
25busypoll        49154/udp                       # busy polling port for ws
26EOF
27        fi
28        update-inetd --group INFO --add "busypoll\tdgram\tudp\twait\tnobody\t/usr/sbin/busyd\tbusyd"
29        ;;
30
31    abort-upgrade|abort-remove|abort-deconfigure)
32        ;;
33
34    *)
35        echo "postinst called with unknown argument \`$1'" >&2
36        exit 1
37        ;;
38esac
39
40# dh_installdeb will replace this with shell code automatically
41# generated by other debhelper scripts.
42
43#DEBHELPER#
44
45exit 0
46
47
Note: See TracBrowser for help on using the repository browser.