source: trunk/debathena/debathena/libnss-nonlocal/debian/rules @ 23113

Revision 23113, 570 bytes checked in by andersk, 16 years ago (diff)
In libnss-nonlocal: * Replace the magic buflen hack with explicit iteration over the nss chain, so that getpwent/getgrent works with nscd enabled. * Fix some memory leaks. * Autotoolfiscate. * Code cleanup.
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3DEB_AUTO_UPDATE_AUTOCONF = 2.50
4DEB_AUTO_UPDATE_AUTOHEADER = 2.50
5DEB_AUTO_UPDATE_AUTOMAKE = 1.9
6DEB_AUTO_UPDATE_ACLOCAL = 1.9
7DEB_AUTO_UPDATE_LIBTOOL = pre
8
9include /usr/share/cdbs/1/rules/debhelper.mk
10include /usr/share/cdbs/1/class/autotools.mk
11
12DEB_CONFIGURE_PREFIX = /
13
14debian/stamp-autotools-files: DEB_AUTO_UPDATE_AUTOMAKE += --foreign --add-missing
15
16debian/stamp-autotools-files: aclocal.m4
17aclocal.m4:
18        touch $@
19
20clean::
21        rm -f aclocal.m4 config.guess config.sub install-sh ltmain.sh \
22            configure config.h.in missing depcomp Makefile.in
Note: See TracBrowser for help on using the repository browser.