source: trunk/debathena/meta/athena-libraries/debian/control @ 25853

Revision 25853, 1.2 KB checked in by jdreed, 10 years ago (diff)
In athena-libraries: * Complete rewrite (Trac: #582) * Drop dynamic logic and manually calculated lists of Athena 9.3 and 9.4 libraries and instead snapshot the current list of recommendations with a focus on reducing them * Remove recommendations with priority 'required' in order to clean up the list: libpng12-0, libc6, libbz2-1.0, libelf1, libgcc1, libglib2.0-0, libncursesw5, libncurses5, libpam06, zlib1g * Remove recommendations with priority 'standard' in order to clean up the list: libx11-6, libxext6, libxml2, libkrb5-3, libk5crypto3, libgssapi-krb5-2, libkrb5support0, libsas2-2 * Condense libogg0, libvorbis0a, libvorbisenc2, and libvorbisfile3 into vorbis-tools * Condense liborbit2, libpopt0, libart-2.0-2, libgnomevfs2-0, libbonobo2-0 and libglib-2.0-0 into libgnome2-0 * Condense libqt3-mt, libxrandr2, and libglu1-mesa into libqt3-mt * Condense libgtk2.0-0, libxfixes3, libgdk-pixbuf-2.0-0, libpango1.0-0, libatk1.0-0, libxdamage1, and libglib-2.0-0 into libgtk2.0-0 * Condense libxcursor1, libxkbfile1, and libsm6 into x11-apps * Condense lesstif2, libfreetype6, libxp6, and libice6 into lesstif2 * Condense libfontconfig1, libfontenc1, libxaw7 (and thus libxpm4), libxcomposite1, libxft2, libxi6, libxinerama1, libxmu6, libxrender1, libxt6, libxtst6, libxv1, libxxf86dga1 and libxxf86vm1 into x11-utils * Add Lintian override for dependency on multiple libstdc++ versions. We do in fact want this, as long as there are libstdc++5 binaries out there (read: forever)
Line 
1Source: debathena-athena-libraries
2Section: debathena/libs
3Priority: extra
4Maintainer: Debathena Project <debathena@mit.edu>
5Build-Depends: debhelper (>= 7.0~)
6Standards-Version: 3.9.3
7
8Package: debathena-athena-libraries
9Architecture: all
10Depends: ${misc:Depends}
11Recommends: freeglut3,
12 guile-1.6-libs,
13 lib32bz2-1.0,
14 lib32gcc1,
15 lib32ncurses5,
16 lib32ncursesw5,
17 lib32z1,
18 libc6-i386,
19 lib32asound2,
20 libasound2,
21 libesd0,
22 lib32gmp3,
23 libgmp3c2,
24 lib32stdc++6,
25 libstdc++5,
26 libstdc++6,
27 libgnome2-0,
28 libgtk2.0-0,
29 vorbis-tools,
30 x11-apps,
31 x11-utils,
32 lesstif2,
33 libxss1,
34 libdb1-compat,
35 libgif4,
36 libgamin0,
37 libhesiod0,
38 libsmbclient,
39 libstartup-notification0,
40 libusb-0.1-4,
41 libutempter0,
42 libwrap0,
43 libgtksourceview1.0-0,
44 ia32-libs
45# Note: libgtksourceview1.0-0 was requested by alexp for
46#       Stata locker.  It is gone in Oneiric+
47# Note: Make some effort to figure out what exactly wants
48#       libxss1 through libwrap0 and whether they're still needed
49Description: Athena libraries for Debathena
50 This metapackage recommends a set of libraries for compatibility with
51 older locker software.  For simplicity, the package may recommend
52 larger packages with both binaries and libraries.
Note: See TracBrowser for help on using the repository browser.