Revision 25610,
837 bytes
checked in by jdreed, 12 years ago
(diff) |
In extra-software:
* include debhelper.mk before adding to the targets, not after.
* Don't tell people to run "soffice", that's just stupid.
|
-
Property svn:executable set to
*
|
Line | |
---|
1 | #!/usr/bin/make -f |
---|
2 | |
---|
3 | HAVE_ICEDTEA = $(shell apt-cache show icedtea6-plugin 2>/dev/null | grep -q '^Version:' && echo y) |
---|
4 | HAVE_LIBREOFFICE = $(shell apt-cache show libreoffice 2>/dev/null | grep -q '^Version:' && echo y) |
---|
5 | |
---|
6 | include /usr/share/cdbs/1/rules/debhelper.mk |
---|
7 | |
---|
8 | ifeq ($(HAVE_ICEDTEA),y) |
---|
9 | binary-predeb/debathena-extra-software:: |
---|
10 | echo "debathena-java-plugin=icedtea6-plugin" >> debian/debathena-extra-software.substvars |
---|
11 | endif |
---|
12 | |
---|
13 | ifeq ($(HAVE_LIBREOFFICE),y) |
---|
14 | install/debathena-extra-software:: |
---|
15 | dh_install debian/ooffice usr/bin |
---|
16 | binary-predeb/debathena-extra-software:: |
---|
17 | echo "debathena-cool-kids-office-suite=libreoffice" >> debian/debathena-extra-software.substvars |
---|
18 | else |
---|
19 | binary-predeb/debathena-extra-software:: |
---|
20 | echo "debathena-cool-kids-office-suite=openoffice.org" >> debian/debathena-extra-software.substvars |
---|
21 | endif |
---|
22 | |
---|
Note: See
TracBrowser
for help on using the repository browser.