source: trunk/third/eog/eog.spec @ 19173

Revision 19173, 2.0 KB checked in by ghudson, 21 years ago (diff)
This commit was generated by cvs2svn to compensate for changes in r19172, which included commits to RCS files with non-trunk default branches.
Line 
1#
2# Note that this is NOT a relocatable package
3#
4
5%define ver      2.2.2
6%define rel      1
7%define prefix   /usr
8%define name     eog
9
10Summary: Eye Of Gnome
11Name: %name
12Version: %ver
13Release: %rel
14Copyright: GPL
15Group: Applications/Multimedia
16Source: ftp://ftp.gnome.org/pub/GNOME/unstable/sources/eog/eog-%{ver}.tar.gz
17BuildRoot: /var/tmp/eog
18Obsoletes: eog
19Packager: Federico Mena-Quintero <federico@gnu.org>
20URL: http://www.gnome.org
21Prereq: /sbin/install-info
22Prefix: %{prefix}
23Docdir: %{prefix}/doc
24Requires: ORBit >= 0.5.0
25Requires: oaf >= 0.3.0
26Requires: gnome-print >= 0.20
27Requires: gdk-pixbuf >= 0.9.0
28Requires: bonobo >= 0.15
29Requires: gconf >= 0.8
30
31%description
32This is the Eye of Gnome, an image viewer program.  It is meant to be
33a fast and functional image viewer as well as an image cataloging
34program.
35
36%changelog
37
38* Mon Sep 04 2000  Federico Mena Quintero  <federico@helixcode.com>
39
40- Updated the spec file; it is still not guaranteed to work out of the
41  box.
42
43
44* Sun Jun 11 2000  Eskil Heyn Olsen <deity@eazel.com>
45
46- Created the .spec file
47
48%prep
49%setup
50
51%build
52# Needed for snapshot releases.
53if [ ! -f configure ]; then
54  CFLAGS="-pipe $RPM_OPT_FLAGS" ./autogen.sh       \
55        --prefix=%{prefix} --sysconfdir=%{sysconfdir} \
56        --localstatedir=%{localstatedir}
57else
58  CFLAGS="-pipe $RPM_OPT_FLAGS" ./configure       \
59        --prefix=%{prefix} --sysconfdir=%{sysconfdir} \
60        --localstatedir=%{localstatedir}
61fi
62
63if [ "$SMP" != "" ]; then
64  (make "MAKE=make -k -j $SMP"; exit 0)
65  make
66else
67  make
68fi
69
70%install
71rm -rf $RPM_BUILD_ROOT
72make install prefix=$RPM_BUILD_ROOT%{prefix} \
73        sysconfdir=$RPM_BUILD_ROOT%{sysconfdir} \
74        localstatedir=$RPM_BUILD_ROOT%{localstatedir}
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%post -p /sbin/ldconfig
80
81%postun -p /sbin/ldconfig
82
83%files
84%defattr(-, root, root)
85%doc AUTHORS COPYING ChangeLog HACKING NEWS README THANKS TODO
86%{prefix}/bin/*
87%{prefix}/share/gnome/apps/*
88%{prefix}/share/pixmaps/*
89%{prefix}/share/locale/*
90%{prefix}/share/oaf/*
91%{prefix}/share/gnome/help/*
92%config /etc/CORBA/*
Note: See TracBrowser for help on using the repository browser.