source: trunk/third/moira/debian/rules @ 26033

Revision 26033, 909 bytes checked in by jdreed, 11 years ago (diff)
Do not in fact remove libtool; remove the kerberos incremental Makefile
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2%:
3        dh $@
4
5override_dh_auto_configure:
6        dh_auto_configure -- \
7        --without-krb4 --with-krb5 --with-hesiod --with-zephyr \
8        --with-com_err=/usr --without-oracle --without-afs \
9        --disable-rpath --with-openssl
10
11override_dh_strip:
12        dh_strip --package=debathena-libmoira0 --dbg-package=debathena-libmoira0-dbg
13        dh_strip --package=debathena-libmrclient0 --dbg-package=debathena-libmrclient0-dbg
14        dh_strip --remaining-packages
15
16override_dh_install:
17        mv debian/tmp/usr/bin/chfn debian/tmp/usr/bin/chfn.moira
18        mv debian/tmp/usr/bin/chsh debian/tmp/usr/bin/chsh.moira
19        mv debian/tmp/usr/share/man/man1/chsh.1 \
20                debian/tmp/usr/share/man/man1/chsh.moira.1
21        mv debian/tmp/usr/share/man/man1/chfn.1 \
22                debian/tmp/usr/share/man/man1/chfn.moira.1
23        dh_install
24
25# Why does distclean not deal with these two makefiles?
26override_dh_clean:
27        dh_clean
28        rm -f util/rsaref/Makefile incremental/kerberos/Makefile
Note: See TracBrowser for help on using the repository browser.