source: trunk/third/nautilus/nautilus.spec @ 21560

Revision 21560, 6.5 KB checked in by ghudson, 19 years ago (diff)
This commit was generated by cvs2svn to compensate for changes in r21559, which included commits to RCS files with non-trunk default branches.
Line 
1%define __spec_install_post /usr/lib/rpm/brp-compress
2Name:             nautilus
3Summary:          Nautilus is a network user environment
4Version:          2.8.2
5Release:          1
6License:          GPL
7Group:            User Interface/Desktop
8Source:           ftp://ftp.gnome.org/pub/GNOME/sources/%{name}-%{version}.tar.gz
9URL:              http://nautilus.eazel.com/
10BuildRoot:        %{_tmppath}/%{name}-%{version}-root
11BuildRequires:    pkgconfig >= 0.8
12Requires:         esound >= 0.2.27
13Requires:         bonobo-activation >= 2.1.0
14Requires:         eel2 >= 2.8.2
15Requires:         glib2 >= 2.3.0
16Requires:         gnome-vfs2 >= 2.5.1
17Requires:         gtk2 >= 2.3.0
18Requires:         libart_lgpl >= 2.3.10
19Requires:         libbonobo >= 2.1.0
20Requires:         libbonoboui >= 2.2.0
21Requires:         libgnome >= 2.1.1
22Requires:         gnome-desktop >= 2.1.0
23Requires:         libgnomeui >= 2.6.0
24Requires:         librsvg2 >= 2.0.1
25Requires:         libxml2 >= 2.4.7
26BuildRequires:    esound-devel >= 0.2.27
27BuildRequires:    bonobo-activation-devel >= 2.1.0
28BuildRequires:    eel2-devel >= 2.8.2
29BuildRequires:    glib2-devel >= 2.3.0
30BuildRequires:    gnome-vfs2-devel >= 2.5.1
31BuildRequires:    gtk2-devel >= 2.3.0
32BuildRequires:    libart_lgpl-devel >= 2.3.10
33BuildRequires:    libbonobo-devel >= 2.1.0
34BuildRequires:    libbonoboui-devel >= 2.2.0
35BuildRequires:    libgnome-devel >= 2.1.1
36BuildRequires:    gnome-desktop-devel >= 2.1.0
37BuildRequires:    libgnomeui-devel >= 2.6.0
38BuildRequires:    librsvg2-devel >= 2.0.1
39BuildRequires:    libxml2-devel >= 2.4.7
40
41
42%description
43Nautilus integrates access to files, applications, media, Internet-based
44resources and the Web.  Nautilus delivers a dynamic and rich user
45experience.  Nautilus is an free software project developed under the
46GNU General Public License and is a core component of the GNOME desktop
47project.
48
49%package devel
50Summary:          Libraries and include files for developing Nautilus components
51Group:            Development/Libraries
52Requires:         %name = %{version}
53Requires:         pkgconfig >= 0.8
54Requires:         esound >= 0.2.27
55Requires:         esound-devel >= 0.2.27
56Requires:         bonobo-activation >= 2.1.0
57Requires:         bonobo-activation-devel >= 2.1.0
58Requires:         eel2 >= 2.8.2
59Requires:         eel2-devel >= 2.8.2
60Requires:         glib2 >= 2.3.0
61Requires:         glib2-devel >= 2.3.0
62Requires:         gnome-vfs2 >= 2.5.1
63Requires:         gnome-vfs2-devel >= 2.5.1
64Requires:         gtk2 >= 2.3.0
65Requires:         gtk2-devel >= 2.3.0
66Requires:         libart_lgpl >= 2.3.10
67Requires:         libart_lgpl-devel >= 2.3.10
68Requires:         libbonobo >= 2.1.0
69Requires:         libbonobo-devel >= 2.1.0
70Requires:         libbonoboui >= 2.2.0
71Requires:         libbonoboui-devel >= 2.2.0
72Requires:         libgnome >= 2.1.1
73Requires:         libgnome-devel >= 2.1.1
74Requires:         gnome-desktop >= 2.1.0
75Requires:         gnome-desktop-devel >= 2.1.0
76Requires:         libgnomeui >= 2.6.0
77Requires:         libgnomeui-devel >= 2.6.0
78Requires:         librsvg2 >= 2.0.1
79Requires:         librsvg2-devel >= 2.0.1
80Requires:         libxml2 >= 2.4.7
81Requires:         libxml2-devel >= 2.4.7
82
83
84%description devel
85This package provides the necessary development libraries and include
86files to allow you to develop Nautilus components.
87
88%prep
89%setup -q
90mv ltmain.sh ltmain.sh.orig
91sed s/relink=yes/relink=no/ ltmain.sh.orig > ltmain.sh
92
93%build
94%configure
95make %{?_smp_mflags}
96
97%install
98[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
99%makeinstall
100
101%find_lang %name
102
103%clean
104[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
105
106%post
107
108%postun
109/sbin/ldconfig
110/usr/bin/scrollkeeper-update
111
112%files -f %name.lang
113%defattr(-, root, root)
114%doc AUTHORS COPYING COPYING-DOCS COPYING.LIB ChangeLog INSTALL
115%doc MAINTAINERS NEWS README THANKS TODO
116#%doc %{_datadir}/gnome/help/*
117%{_sysconfdir}/gconf/*
118%{_sysconfdir}/X11/serverconfig/.directory
119%{_sysconfdir}/X11/starthere/*
120%{_sysconfdir}/X11/starthere/.directory
121%{_sysconfdir}/X11/sysconfig/.directory
122%{_bindir}/*
123%{_libdir}/*.so*
124%{_libdir}/bonobo/libnautilus-*-view.so
125%{_libdir}/bonobo/servers/*
126%{_libexecdir}/*
127%{_datadir}/applications/*
128%{_datadir}/gnome-2.0/ui/*
129%{_datadir}/idl/*
130%{_datadir}/nautilus
131%{_datadir}/locale/*/*
132%{_datadir}/pixmaps/*
133%{_datadir}/gnome/network/*
134#%doc %{_datadir}/omf/nautilus/*
135
136
137%files devel
138%defattr(-, root, root)
139%{_includedir}/*
140%{_libdir}/*.so
141%{_libdir}/*a
142%{_libdir}/pkgconfig/*
143
144
145%changelog
146* Tue Mar 12 2003 Neil Weisenfeld <weisen@ai.mit.edu>
147- Added various file targets: gnome/network, the libexecdir stuff,
148  locale, gconf (do we need to register this somehow?)
149- Fixed nautilus-tree-view to come from lib/bonobo instead of lib/
150- Actually, now pick up nautilus-*-view.so from lib/bonobo
151- Commented out omf and gnome/help documentation.  (should this be
152  coming from somewhere else?)
153- killed dependence on ltmain-fixed.sh as we're "fixing" it in the %prep
154
155* Tue Mar 05 2002 Chris Chabot <chabotc@reviewboard.com>
156- Fixed file list
157- ltmain.sh fix
158- fixed last format issues
159- converted to .spec.in
160
161* Mon Feb 04 2002 Roy-Magne Mo  <rmo@sunnmore.net>
162- Fixed lang
163
164* Sun Feb 03 2002 Roy-Magne Mo  <rmo@sunnmore.net>
165- Added buildrequires
166
167* Sat Jan 19 2002 Chris Chabot <chabotc@reviewboard.com>
168- Minor changes & restored macro's
169- Major cleanups
170- Moved versions to defines
171- Since entry below hints at removing sugested, extras, remove their headers
172
173* Fri Jan 18 2002  <builder@localhost.localdomain>
174- removed some unnecessary %defines
175- got rid of suggested and extras packages, to make life easier
176- re-write %files section from scratch
177- made setup quiet
178- fixed %post and %postun scripts
179- removed -k from make lines (it's silly for RPMs)
180
181* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
182- Added BuildRequires lines
183- Changed Source to point to ftp.gnome.org instead of just the tarball name
184- Moved %description sections closer to their %package sections
185- Moved %changelog to the end, where so that it's not in the way
186- Changed configure and make install options to allow moving of
187libraries, includes, binaries more easily
188- Removed hard-coded paths (don't define %prefix or %docdir)
189- replace %{prefix}/bin with %{_bindir}
190- replace %{prefix}/share with %{_datadir}
191- replace %{prefix}/lib with %{_libdir}
192- replace %{prefix}/include with %{_includedir}
193
194* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
195- removed obsoletes from sub packages and added mozilla and trilobite
196subpackages
197
198* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
199- created this thing
Note: See TracBrowser for help on using the repository browser.