source: trunk/athena/bin/quota/debian/debathena-quota.postinst @ 23328

Revision 23328, 1.1 KB checked in by tabbott, 15 years ago (diff)
In quota: * Remove DEB_AUTO_UPDATE_DEBIAN_CONTROL. * Change DEB_AUTO_UPDATE_AUTOCONF to 2.50, not 1. * Clean up debian/copyright. * Fix typo in postinst script. * Change "Debian-Athena Project" to "Debathena Project". * Remove debian/control from version control.
Line 
1#!/bin/sh
2# postinst script for debathena-quota
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20
21case "$1" in
22    configure)
23        # Setup quota binary for setgid-attach.
24        if ! dpkg-statoverride --list /usr/bin/quota.debathena >/dev/null; then
25            chgrp attach /usr/bin/quota.debathena
26            chmod a=rx,u+w,g+s /usr/bin/quota.debathena
27        fi
28        ;;
29
30    abort-upgrade|abort-remove|abort-deconfigure)
31        ;;
32
33    *)
34        echo "postinst called with unknown argument \`$1'" >&2
35        exit 1
36    ;;
37esac
38
39# dh_installdeb will replace this with shell code automatically
40# generated by other debhelper scripts.
41
42#DEBHELPER#
43
44exit 0
45
46
Note: See TracBrowser for help on using the repository browser.