source: trunk/athena/bin/quota/debian/rules @ 25419

Revision 25419, 568 bytes checked in by jdreed, 13 years ago (diff)
In quota: * Don't use /usr/lib/afs/libcom_err.a if it doesn't exist
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3DEB_AUTO_UPDATE_AUTOCONF = 2.50
4include /usr/share/cdbs/1/rules/debhelper.mk
5include /usr/share/cdbs/1/class/autotools.mk
6
7DEB_CONFIGURE_EXTRA_FLAGS += --with-afs=/usr --disable-nfs --with-hesiod --with-zephyr $(if $(wildcard /usr/lib/afs/libcom_err.a),LIBS=/usr/lib/afs/libcom_err.a)
8CPPFLAGS += -D_LINUX_QUOTA_VERSION=1
9
10common-install-impl::
11        mv $(DEB_DESTDIR)/usr/bin/quota $(DEB_DESTDIR)/usr/bin/quota.debathena
12        mv $(DEB_DESTDIR)/usr/share/man/man1/quota.1 \
13            $(DEB_DESTDIR)/usr/share/man/man1/quota.debathena.1
14
15clean::
16        rm -f configure
Note: See TracBrowser for help on using the repository browser.