source: trunk/debathena/config/cluster-login-config/debian/rules @ 24848

Revision 24848, 2.3 KB checked in by jdreed, 14 years ago (diff)
Revert r24847 and fix the transform to deal with karmic
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3GDM_VERSION = $(shell dpkg-query --showformat='$${Version}' --show gdm)
4NEW_GDM = $(shell dpkg --compare-versions $(GDM_VERSION) ge '2.25.2~' && echo y)
5EVENT_D = $(shell test -f /etc/event.d/tty1 && echo y)
6
7DEB_DIVERT_EXTENSION = .debathena
8ifneq ($(wildcard /etc/gdm/gdm.conf-custom.debathena),)
9    GDM_CONFFILE = /etc/gdm/gdm.conf-custom.debathena.debathena
10else
11    GDM_CONFFILE = /etc/gdm/gdm.conf.debathena.debathena
12endif
13DEB_UNDIVERT_FILES_debathena-cluster-login-config += \
14        /etc/default/kexec.debathena
15DEB_UNDIVERT_VERSION_/etc/default/kexec.debathena = 1.23~
16
17ifneq ($(NEW_GDM),y)
18    DEB_TRANSFORM_FILES_debathena-cluster-login-config += \
19        ${GDM_CONFFILE}
20else
21    DEB_REMOVE_FILES_debathena-cluster-login-config += \
22        /usr/share/xsessions/gnome-failsafe.desktop \
23        /usr/share/xsessions/xterm.desktop
24    DEB_TRANSFORM_FILES_debathena-cluster-login-config += \
25        /etc/pam.d/gdm.debathena.debathena
26    DEB_TRANSFORM_FILES_debathena-cluster-login-config += \
27        /etc/dbus-1/system.d/gdm.conf.debathena
28endif
29
30DEB_REMOVE_FILES_debathena-cluster-login-config += \
31    /usr/lib/indicator-session/indicator-users-service
32
33DEB_DIVERT_FILES_debathena-cluster-login-config += \
34        /sbin/getty.debathena
35
36ifeq ($(EVENT_D),y)
37    DEB_UNREMOVE_FILES_debathena-cluster-login-config += \
38        /etc/event.d/tty1 \
39        /etc/event.d/tty2 \
40        /etc/event.d/tty3 \
41        /etc/event.d/tty4 \
42        /etc/event.d/tty5 \
43        /etc/event.d/tty6
44    DEB_UNREMOVE_VERSION_/etc/event.d/tty1 = 1.24~
45    DEB_UNREMOVE_VERSION_/etc/event.d/tty2 = 1.24~
46    DEB_UNREMOVE_VERSION_/etc/event.d/tty3 = 1.24~
47    DEB_UNREMOVE_VERSION_/etc/event.d/tty4 = 1.24~
48    DEB_UNREMOVE_VERSION_/etc/event.d/tty5 = 1.24~
49    DEB_UNREMOVE_VERSION_/etc/event.d/tty6 = 1.24~
50else
51    DEB_UNREMOVE_FILES_debathena-cluster-login-config += \
52        /etc/init/tty1.conf \
53        /etc/init/tty2.conf \
54        /etc/init/tty3.conf \
55        /etc/init/tty4.conf \
56        /etc/init/tty5.conf \
57        /etc/init/tty6.conf
58    DEB_UNREMOVE_VERSION_/etc/init/tty1.conf = 1.24~
59    DEB_UNREMOVE_VERSION_/etc/init/tty2.conf = 1.24~
60    DEB_UNREMOVE_VERSION_/etc/init/tty3.conf = 1.24~
61    DEB_UNREMOVE_VERSION_/etc/init/tty4.conf = 1.24~
62    DEB_UNREMOVE_VERSION_/etc/init/tty5.conf = 1.24~
63    DEB_UNREMOVE_VERSION_/etc/init/tty6.conf = 1.24~
64endif
65
66include /usr/share/cdbs/1/rules/debhelper.mk
67include /usr/share/cdbs/1/rules/config-package.mk
Note: See TracBrowser for help on using the repository browser.