Revision 24493,
938 bytes
checked in by broder, 15 years ago
(diff) |
In gconf2-config:
* Configure gconf through /usr/share/gconf/default.path instead of
/etc/gconf/2/path, as it makes ucf less likely to do dumb
things. (Trac: #247)
|
-
Property svn:executable set to
*
|
Line | |
---|
1 | #!/usr/bin/make -f |
---|
2 | |
---|
3 | DEB_DIVERT_EXTENSION = .debathena |
---|
4 | DEB_TRANSFORM_FILES_debathena-gconf2-config += \ |
---|
5 | /usr/share/gconf/default.path.debathena |
---|
6 | |
---|
7 | DEB_UNDIVERT_FILES_debathena-gconf2-config += \ |
---|
8 | /etc/gconf/2/path.debathena |
---|
9 | DEB_UNDIVERT_VERSION_/etc/gconf/2/path.debathena = 1.7~ |
---|
10 | |
---|
11 | include /usr/share/cdbs/1/rules/debhelper.mk |
---|
12 | include /usr/share/cdbs/1/rules/config-package.mk |
---|
13 | |
---|
14 | GCONF_FILES = debian/gconf.afs debian/gconf.local debian/gconf. |
---|
15 | |
---|
16 | common-build-indep:: $(GCONF_FILES) |
---|
17 | |
---|
18 | DISTRO = $(shell lsb_release --short --id) |
---|
19 | SUFFIX = $(SUFFIX-$(DISTRO)) |
---|
20 | SUFFIX-Debian = -debathena |
---|
21 | SUFFIX-Ubuntu = -debathena-ubuntu |
---|
22 | RELEASE = $(shell lsb_release --short --codename) |
---|
23 | |
---|
24 | ifeq ($(SUFFIX),) |
---|
25 | $(error Unknown distro $(DISTRO).) |
---|
26 | endif |
---|
27 | |
---|
28 | debian/gconf.afs: |
---|
29 | echo 'xml:readwrite:$$(HOME)/.gconf-debathena-$(RELEASE)' > $@ |
---|
30 | |
---|
31 | debian/gconf.local: |
---|
32 | echo 'xml:readwrite:$$(HOME)/.gconf' > $@ |
---|
33 | |
---|
34 | debian/gconf.: |
---|
35 | ln -sf gconf.local $@ |
---|
36 | |
---|
37 | clean:: |
---|
38 | rm -f $(GCONF_FILES) |
---|
Note: See
TracBrowser
for help on using the repository browser.