source: trunk/debathena/config/gconf2-config/debian/rules @ 23405

Revision 23405, 999 bytes checked in by tabbott, 15 years ago (diff)
In gconf2-config: * Remove DEB_AUTO_UPDATE_DEBIAN_CONTROL. * Change "Debian-Athena Project" to "Debathena Project". * Remove debian/control from version control. * Clean up debian/copyright.
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3DEB_DIVERT_EXTENSION = .debathena
4ifneq ($(wildcard /usr/share/gconf/default.path),)
5    GCONF2_PATH = /usr/share/gconf/default.path
6    DEB_CHECK_FILES_SOURCE_/etc/gconf/2/path = $(GCONF2_PATH)
7else
8    GCONF2_PATH = /etc/gconf/2/path
9endif
10DEB_TRANSFORM_FILES_debathena-gconf2-config += \
11        /etc/gconf/2/path.debathena
12include /usr/share/cdbs/1/rules/debhelper.mk
13include /usr/share/cdbs/1/rules/config-package.mk
14
15GCONF_FILES = debian/gconf.afs debian/gconf.local debian/gconf.
16
17common-build-indep:: $(GCONF_FILES)
18
19DISTRO = $(shell lsb_release --short --id)
20SUFFIX = $(SUFFIX-$(DISTRO))
21SUFFIX-Debian = -debathena
22SUFFIX-Ubuntu = -debathena-ubuntu
23RELEASE = $(shell lsb_release --short --codename)
24
25ifeq ($(SUFFIX),)
26        $(error Unknown distro $(DISTRO).)
27endif
28
29debian/gconf.afs:
30        echo 'xml:readwrite:$$(HOME)/.gconf-debathena-$(RELEASE)' > $@
31
32debian/gconf.local:
33        echo 'xml:readwrite:$$(HOME)/.gconf' > $@
34
35debian/gconf.:
36        ln -sf gconf.local $@
37
38clean::
39        rm -f $(GCONF_FILES)
Note: See TracBrowser for help on using the repository browser.