source: trunk/debathena/config/printing-config/debian/rules @ 24595

Revision 24595, 1.5 KB checked in by broder, 14 years ago (diff)
In printing-config: * Add a test suite for debathena.printing and run it during package builds.
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3DEB_PYTHON_SYSTEM = pysupport
4
5DEB_DIVERT_EXTENSION = .debathena
6
7DEB_DIVERT_FILES_debathena-printing-config += \
8        /usr/bin/lp.debathena \
9        /usr/bin/lpq.debathena \
10        /usr/bin/lpr.debathena \
11        /usr/bin/lprm.debathena \
12        \
13        /usr/share/man/man1/lp.debathena.1.gz \
14        /usr/share/man/man1/lpq.debathena.1.gz \
15        /usr/share/man/man1/lpr.debathena.1.gz \
16        /usr/share/man/man1/lprm.debathena.1.gz \
17
18DEB_UNDIVERT_FILES_debathena-printing-config += \
19        /usr/bin/cancel.debathena \
20        /usr/sbin/lpc.debathena \
21        /usr/share/man/man1/cancel.debathena.1.gz \
22        /usr/share/man/man8/lpc.debathena.8.gz
23
24DEB_UNDIVERT_VERSION_/usr/bin/cancel.debathena = 1.17~
25DEB_UNDIVERT_VERSION_/usr/sbin/lpc.debathena = 1.17~
26DEB_UNDIVERT_VERSION_/usr/share/man/man1/cancel.debathena.1.gz = 1.17~
27DEB_UNDIVERT_VERSION_/usr/share/man/man8/lpc.debathena.8.gz = 1.17~
28
29include /usr/share/cdbs/1/rules/debhelper.mk
30include /usr/share/cdbs/1/rules/config-package.mk
31include /usr/share/cdbs/1/class/python-distutils.mk
32
33build/debathena-printing-config:: system-config-printer.mo
34system-config-printer.mo: system-config-printer.po
35        msgfmt -o $@ $<
36
37ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
38common-build-arch common-build-indep:: $(addprefix python-check-stamp-, $(cdbs_python_build_versions))
39python-check-stamp-%: python-build-stamp-%
40        $(call cdbs_python_binary,python$(cdbs_python_compile_version)) setup.py nosetests
41        touch $@
42
43clean::
44        rm -rf python-check-stamp-* mox-*.egg .coverage
45endif
46
47clean::
48        rm -rf debathena.printing.egg-info system-config-printer.mo
Note: See TracBrowser for help on using the repository browser.