source: trunk/debathena/config/reactivate/debian/debathena-reactivate.postinst @ 23789

Revision 23789, 1.4 KB checked in by geofft, 15 years ago (diff)
reactivate: Try a more plausible approach
  • Property svn:executable set to *
Line 
1#!/bin/sh
2# postinst script for #PACKAGE#
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20
21case "$1" in
22    configure)
23        # Users logging in will be added to several different
24        # groups. Make sure they all exist.
25        for group in $(sed -ne 's/^addgroups="\(.*\)"/\1/p' /usr/sbin/athena-login-snapshot); do
26            getent group "$group" >/dev/null || addgroup --system "$group"
27        done
28        cat >>/etc/sudoers <<EOF
29### BEGIN debathena-reactivate
30Defaults:%admin lecture_file=/etc/athena/sudo-warning, lecture=once
31### END debathena-reactivate
32EOF
33
34    ;;
35
36    abort-upgrade|abort-remove|abort-deconfigure)
37    ;;
38
39    *)
40        echo "postinst called with unknown argument \`$1'" >&2
41        exit 1
42    ;;
43esac
44
45# dh_installdeb will replace this with shell code automatically
46# generated by other debhelper scripts.
47
48#DEBHELPER#
49
50exit 0
51
52
Note: See TracBrowser for help on using the repository browser.