source: trunk/debathena/debathena/libnss-nonlocal/debian/rules @ 24755

Revision 24755, 3.1 KB checked in by andersk, 14 years ago (diff)
In libnss-nonlocal: * Install lib32nss-nonlocal to the right place on Ubuntu.
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3DEB_AUTO_UPDATE_AUTOCONF = 2.50
4DEB_AUTO_UPDATE_AUTOHEADER = 2.50
5DEB_AUTO_UPDATE_AUTOMAKE = 1.9
6DEB_AUTO_UPDATE_ACLOCAL = 1.9
7DEB_AUTO_UPDATE_LIBTOOL = pre
8
9# Fix http://bugs.debian.org/576967 : CDBS 0.4.77 in squeeze
10# incorrectly splits multiword $(CC) and $(CXX).
11override cdbs_set_nondefaultvars = $(foreach var,$1,$(if $(filter-out $(origin $(var)),default),$(var)='$($(var))'))
12
13include /usr/share/cdbs/1/rules/debhelper.mk
14include /usr/share/cdbs/1/class/autotools.mk
15
16DEB_DESTDIR = $(CURDIR)/debian/tmp/
17DEB_DH_INSTALL_SOURCEDIR = $(DEB_DESTDIR)
18DEB_CONFIGURE_PREFIX = /
19
20IS_UBUNTU := $(if $(filter Ubuntu,$(shell lsb_release -is)),y)
21LIBC6_VERSION := $(shell dpkg-query --showformat='$${Version}' --show libc6)
22libc6_ge = $(shell dpkg --compare-versions '$(LIBC6_VERSION)' ge '$(1)' && echo y)
23
24ifeq ($(call libc6_ge,2.8+20080809),y)
25    DEB_DH_SHLIBDEPS_ARGS = -- -xglibc-private
26endif
27
28debian/stamp-autotools-files: DEB_AUTO_UPDATE_AUTOMAKE += --foreign --add-missing
29
30debian/stamp-autotools-files: aclocal.m4
31aclocal.m4:
32        touch $@
33
34DEB_BUILDDIR = $(or $(DEB_BUILDDIR_$(cdbs_curpkg)),debian/build)
35
36REAL_DEB_HOST_GNU_TYPE := $(DEB_HOST_GNU_TYPE)
37
38DEB_BUILDDIR_lib32nss-nonlocal = debian/build_32
39cleanbuilddir/lib32nss-nonlocal:: clean/lib32nss-nonlocal
40configure/lib32nss-nonlocal:: cdbs_crossbuild =
41# i386_configure_target in eglibc/debian/sysdeps/amd64.mk
42ifeq ($(or $(IS_UBUNTU),$(call libc6_ge,2.8+20080809)),y)
43configure/lib32nss-nonlocal:: DEB_BUILD_GNU_TYPE = i686-linux
44else
45configure/lib32nss-nonlocal:: DEB_BUILD_GNU_TYPE = i486-linux
46endif
47# i386_CC in eglibc/debian/sysdeps/amd64.mk
48configure/lib32nss-nonlocal:: CC += -m32
49# i386_slibdir in eglibc/debian/sysdeps/amd64.mk
50ifeq ($(or $(IS_UBUNTU),$(call libc6_ge,2.9-14~)),y)
51configure/lib32nss-nonlocal:: DEB_CONFIGURE_EXTRA_FLAGS += --libdir="\$${prefix}/lib32"
52binary-install/lib32nss-nonlocal:: DEB_DH_INSTALL_ARGS = 'lib32/*'
53else
54configure/lib32nss-nonlocal:: DEB_CONFIGURE_PREFIX = /emul/ia32-linux
55binary-install/lib32nss-nonlocal:: DEB_DH_INSTALL_ARGS = 'emul/ia32-linux/lib/*'
56endif
57
58DEB_BUILDDIR_lib64nss-nonlocal = debian/build_64
59cleanbuilddir/lib64nss-nonlocal:: clean/lib64nss-nonlocal
60configure/lib64nss-nonlocal:: cdbs_crossbuild =
61# amd64_configure_target in eglibc/debian/sysdeps/i386.mk
62configure/lib64nss-nonlocal:: DEB_BUILD_GNU_TYPE = x86_64-linux
63# amd64_CC in eglibc/debian/sysdeps/i386.mk
64configure/lib64nss-nonlocal:: CC += -m64 -D__x86_64__
65# amd64_slibdir in eglibc/debian/sysdeps/i386.mk
66configure/lib64nss-nonlocal:: DEB_CONFIGURE_EXTRA_FLAGS += --libdir="\$${prefix}/lib64"
67
68configure/lib32nss-nonlocal configure/lib64nss-nonlocal::
69        $(DEB_CONFIGURE_INVOKE) $(cdbs_configure_flags) $(DEB_CONFIGURE_EXTRA_FLAGS) $(DEB_CONFIGURE_USER_FLAGS)
70
71build/lib32nss-nonlocal build/lib64nss-nonlocal::
72        +$(DEB_MAKE_INVOKE) $(DEB_MAKE_BUILD_TARGET)
73
74install/lib32nss-nonlocal install/lib64nss-nonlocal::
75        +$(DEB_MAKE_INVOKE) $(DEB_MAKE_INSTALL_TARGET)
76
77clean/lib32nss-nonlocal clean/lib64nss-nonlocal::
78        +-$(DEB_MAKE_INVOKE) -k $(DEB_MAKE_CLEAN_TARGET)
79
80clean::
81        rm -f aclocal.m4 config.guess config.sub install-sh ltmain.sh \
82            configure config.h.in missing depcomp Makefile.in
Note: See TracBrowser for help on using the repository browser.