source: trunk/debathena/debathena/libnss-nonlocal/debian/rules @ 25083

Revision 25083, 3.5 KB checked in by andersk, 13 years ago (diff)
In nss_nonlocal: * New upstream release. - Fix errno saving and restoring. - Document nss-nonlocal-users and nss-local-users groups in README. - Allow local whitelisting of nonlocal user and group memberships, using the magic local ‘nss-nonlocal-users’ user and group. * Create magic ‘nss-nonlocal-users’ user. * Remove obsolete exclusion of glibc-private dependency. * Use automake 1.10 and autoconf 2.61. * Add multiarch support for distros from the future. * Disable dh_buildinfo, which currently fails at multiarch. Full history: git://andersk.mit.edu/nss_nonlocal.git debian/2.0-0debathena1
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3DEB_AUTO_UPDATE_AUTOCONF = 2.61
4DEB_AUTO_UPDATE_AUTOHEADER = 2.61
5DEB_AUTO_UPDATE_AUTOMAKE = 1.10
6DEB_AUTO_UPDATE_ACLOCAL = 1.10
7DEB_AUTO_UPDATE_LIBTOOL = pre
8
9# dh_buildinfo fails at multiarch: http://bugs.debian.org/620104
10CDBS_BUILD_DEPENDS_rules_debhelper_buildinfo =
11
12include /usr/share/cdbs/1/rules/debhelper.mk
13include /usr/share/cdbs/1/class/autotools.mk
14
15DEB_DESTDIR = $(CURDIR)/debian/tmp/
16DEB_DH_INSTALL_SOURCEDIR = $(DEB_DESTDIR)
17DEB_CONFIGURE_PREFIX = /
18
19ifneq ($(DEB_HOST_MULTIARCH),)
20    export DH_COMPAT = 9
21    DEB_CONFIGURE_EXTRA_FLAGS += $(MULTIARCH_CONFIGURE_FLAGS)
22    MULTIARCH_CONFIGURE_FLAGS = --libdir='$${prefix}/lib/$(DEB_HOST_MULTIARCH)'
23    DEB_DH_GENCONTROL_ARGS_libnss-nonlocal += -- -DMulti-Arch=same
24endif
25
26IS_UBUNTU := $(if $(filter Ubuntu,$(shell lsb_release -is)),y)
27LIBC6_VERSION := $(shell dpkg-query --showformat='$${Version}' --show libc6)
28libc6_ge = $(shell dpkg --compare-versions '$(LIBC6_VERSION)' ge '$(1)' && echo y)
29
30debian/stamp-autotools-files: DEB_AUTO_UPDATE_AUTOMAKE += --foreign --add-missing
31
32debian/stamp-autotools-files: aclocal.m4
33aclocal.m4:
34        touch $@
35
36DEB_BUILDDIR = $(or $(DEB_BUILDDIR_$(cdbs_curpkg)),debian/build)
37
38REAL_DEB_HOST_GNU_TYPE := $(DEB_HOST_GNU_TYPE)
39
40DEB_BUILDDIR_lib32nss-nonlocal = debian/build_32
41cleanbuilddir/lib32nss-nonlocal:: clean/lib32nss-nonlocal
42configure/lib32nss-nonlocal:: MULTIARCH_CONFIGURE_FLAGS =
43configure/lib32nss-nonlocal:: cdbs_crossbuild =
44# i386_configure_target in eglibc/debian/sysdeps/amd64.mk
45ifeq ($(or $(IS_UBUNTU),$(call libc6_ge,2.8+20080809)),y)
46configure/lib32nss-nonlocal:: DEB_BUILD_GNU_TYPE = i686-linux
47else
48configure/lib32nss-nonlocal:: DEB_BUILD_GNU_TYPE = i486-linux
49endif
50# i386_CC in eglibc/debian/sysdeps/amd64.mk
51configure/lib32nss-nonlocal:: CC += -m32
52# i386_slibdir in eglibc/debian/sysdeps/amd64.mk
53ifeq ($(or $(IS_UBUNTU),$(call libc6_ge,2.9-14~)),y)
54configure/lib32nss-nonlocal:: DEB_CONFIGURE_EXTRA_FLAGS += --libdir="\$${prefix}/lib32"
55binary-install/lib32nss-nonlocal:: DEB_DH_INSTALL_ARGS = 'lib32/*'
56else
57configure/lib32nss-nonlocal:: DEB_CONFIGURE_PREFIX = /emul/ia32-linux
58binary-install/lib32nss-nonlocal:: DEB_DH_INSTALL_ARGS = 'emul/ia32-linux/lib/*'
59endif
60
61DEB_BUILDDIR_lib64nss-nonlocal = debian/build_64
62cleanbuilddir/lib64nss-nonlocal:: clean/lib64nss-nonlocal
63configure/lib64nss-nonlocal:: MULTIARCH_CONFIGURE_FLAGS =
64configure/lib64nss-nonlocal:: cdbs_crossbuild =
65# amd64_configure_target in eglibc/debian/sysdeps/i386.mk
66configure/lib64nss-nonlocal:: DEB_BUILD_GNU_TYPE = x86_64-linux
67# amd64_CC in eglibc/debian/sysdeps/i386.mk
68configure/lib64nss-nonlocal:: CC += -m64 -D__x86_64__
69# amd64_slibdir in eglibc/debian/sysdeps/i386.mk
70configure/lib64nss-nonlocal:: DEB_CONFIGURE_EXTRA_FLAGS += --libdir="\$${prefix}/lib64"
71
72# Fix for CDBS ≥ 0.4.59ubuntu4, < 0.4.83ubuntu1 (karmic and lucid).
73configure/lib32nss-nonlocal configure/lib64nss-nonlocal:: DEB_CONFIGURE_SCRIPT_ENV += CC="$(CC)"
74
75configure/lib32nss-nonlocal configure/lib64nss-nonlocal::
76        $(DEB_CONFIGURE_INVOKE) $(cdbs_configure_flags) $(DEB_CONFIGURE_EXTRA_FLAGS) $(DEB_CONFIGURE_USER_FLAGS)
77
78build/lib32nss-nonlocal build/lib64nss-nonlocal::
79        +$(DEB_MAKE_INVOKE) $(DEB_MAKE_BUILD_TARGET)
80
81install/lib32nss-nonlocal install/lib64nss-nonlocal::
82        +$(DEB_MAKE_INVOKE) $(DEB_MAKE_INSTALL_TARGET)
83
84clean/lib32nss-nonlocal clean/lib64nss-nonlocal::
85        +-$(DEB_MAKE_INVOKE) -k $(DEB_MAKE_CLEAN_TARGET)
86
87clean::
88        rm -f aclocal.m4 config.guess config.sub install-sh ltmain.sh \
89            configure config.h.in missing depcomp Makefile.in
Note: See TracBrowser for help on using the repository browser.