Ticket #1038 (closed enhancement: wontfix)

Opened 10 years ago

Last modified 9 years ago

Don't scribble over the utility partition

Reported by: jdreed Owned by:
Priority: normal Milestone: The Distant Future
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

PC service would appreciate it if we could keep the utility partition intact, as it makes their lives easier when working on cluster machines.

Change History

comment:1 Changed 10 years ago by geofft

I ran across the  dell-recovery package, which also includes dell-recovery-bootloader and dell-recovery-casper packages starting from Natty. I wonder if this is in any way useful to us.

Probably the most interesting thing will be if, given that all this is upstream, Dell has upstreamed the partman configuration to keep a utility parition when they image Ubuntu systems.

comment:2 Changed 9 years ago by jdreed

This is actually slightly harder, in that we can configure partman to use the largest free space, and use an early_command to delete the windows install. The problem is that at least on some newer machines, the 'de' partition only contains a bare-bones DOS install and some other stuff? Additional diagnostics appear to be on on an ntfs partition. I don't know that we have a good way to programmatically deal -- I need to get my hands on a clean 7010 at some point. I suspect the best thing is "Delete the largest Windows partition, and then tell partman to use that free space"

comment:3 Changed 9 years ago by jdreed

This may also be moot, in that modern machines appear to have diagnostics built in to the UEFI ROM

comment:4 Changed 9 years ago by jdreed

  • Status changed from new to closed
  • Resolution set to wontfix

All the UEFI machines have built-in diagnostics, and it's not worth our time to deal with the 760s and 780s.

Note: See TracTickets for help on using tickets.